Page MenuHomeSolus
Feed Advanced Search

Yesterday

aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

This is related with my post:
https://dev.getsol.us/T8715

Fri, Feb 21, 2:14 AM · Hardware
aquasp added a comment to T8715: Intel UHD 620 - GL Issues.

I can confirm this helps.
https://dev.getsol.us/T8752

Fri, Feb 21, 2:14 AM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Also, how can I enable notifications for this post?

Fri, Feb 21, 1:12 AM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Btw, I will wait until kernel 5.6 arrives and then I will try to install xorg intel again and see if the issues continues

Fri, Feb 21, 1:10 AM · Hardware

Thu, Feb 20

moriel5 added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

@aquasp Yes, I do (both actually, the 32-bit package for Wine support), as well as the others (though these are more for cases where I need to boot from another PC).

Thu, Feb 20, 9:04 PM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Do you have mesa lib and mesa lib 32 installed? I also installed all libvas and libvdpaus, but I think it is not related to xorg intel

Thu, Feb 20, 8:47 PM · Hardware
moriel5 added a comment to T3147: OpenCL platform unavailable.

Extremely late update, since I had forgotten all about it, and I'm usually not at home.
My fake "7570" has apparently gotten damaged at the same time as my DH55HC motherboard (thankfully it was just the RTC chip, and I got a new one of the same model, however I still need to find someone that will be able to help me replace it).
It still works, but not very well, with VGA having limited resolutions (up to something like 1366x768p), and ignoring the actual monitor's settings, and DVI getting a black screen, no idea about HDMI.

Thu, Feb 20, 8:09 PM · Hardware
moriel5 added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

@DataDrake Then in that case, I'll check whether this solves the "blank screen on wake" issue that's been plaguing every PC using Intel graphics I had installed Solus on since kernel ~4.19 (granted, it happens much less often, and is a minor issue since I just need to switch TTYs, but it still happens,and the less bugs, the better).

Thu, Feb 20, 7:16 PM · Hardware
DataDrake added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

@moriel5 I don't know where the cut-off is, TBH. I do know that it was a problem on my i5-4570R which was first-gen Iris on Haswell.

Thu, Feb 20, 7:07 PM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Also, I noticed that "disable animations" option was not working with those xorg drivers installed

Thu, Feb 20, 6:52 PM · Hardware
moriel5 added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

@DataDrake Thanks, I see I had mixed the KMS driver with the DDX driver, and the Mesa driver with the KMS driver.
So in short, anything relying on Gen7 or older?

Thu, Feb 20, 6:49 PM · Hardware
DataDrake added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

@moriel5 Nothing like that. The Xorg DDX drivers provide additional optimizations and features to Xorg on top of the KMS driver. Without it, Xorg falls back to the Modesetting DDX driver which still uses the KMS driver as a backend and can do some optimizations and things. It's also worth noting that most of the DDX functionality is focused on 2D rendering which isn't used as much these days with GTK and Qt moving towards GL-based 3D rendering.

Thu, Feb 20, 6:17 PM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Well, I call solus Help Center as Solus wifi haha

Thu, Feb 20, 6:04 PM · Hardware
moriel5 added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

I'm curious, what does X-Org rely upon if you remove the driver, CPU-based graphics?

Thu, Feb 20, 5:50 PM · Hardware
DataDrake added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

Also, there is no Solus Wiki :P

Thu, Feb 20, 5:28 PM · Hardware
DataDrake added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

KMS = Kernel Mode-Setting.

Thu, Feb 20, 5:28 PM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

This happens from time to time and I've never been able to nail down who should and shouldn't have the Xorg driver over the KMS driver. Might be worth trying to remove it on the 4.2 ISO as a test.

Thu, Feb 20, 5:24 PM · Hardware
DataDrake triaged T8752: xorg-driver-video-intel causing freezes (intel igpu) as Needs More Info priority.

This happens from time to time and I've never been able to nail down who should and shouldn't have the Xorg driver over the KMS driver. Might be worth trying to remove it on the 4.2 ISO as a test.

Thu, Feb 20, 5:14 PM · Hardware
aquasp added a comment to T8752: xorg-driver-video-intel causing freezes (intel igpu).

I also did a post here:
https://discuss.getsol.us/d/3866-needs-confirmation-removing-xorg-intel-stops-freezing-problem-intel

Thu, Feb 20, 4:54 PM · Hardware
aquasp created T8752: xorg-driver-video-intel causing freezes (intel igpu).
Thu, Feb 20, 4:53 PM · Hardware

Wed, Feb 19

DataDrake closed T8728: enable CONFIG_NVME_HWMON in kernel as Resolved by committing R3571:0164934fd585: Updated to 5.5.4.
Wed, Feb 19, 2:17 PM · Hardware

Mon, Feb 17

sam_f added a comment to T83: Brother Drivers.

I'm planning to buy a new printer, but i fear it's not supported by Solus, now.
Will the Brother MFC-L2750DW be supported in the future ?

Mon, Feb 17, 8:16 PM · Hardware

Sat, Feb 15

DataDrake closed T8731: Intel Wireless 3168NGW not working after kernel update to 5.5.3 as Resolved.

Go forth and enjoy!

Sat, Feb 15, 2:27 AM · Hardware

Fri, Feb 14

DataDrake claimed T8731: Intel Wireless 3168NGW not working after kernel update to 5.5.3.
Fri, Feb 14, 11:47 PM · Hardware
DataDrake added a comment to T8731: Intel Wireless 3168NGW not working after kernel update to 5.5.3.

Yeah I know. Needs this patch: https://patchwork.kernel.org/patch/11353871/

Fri, Feb 14, 11:46 PM · Hardware
camtron created T8731: Intel Wireless 3168NGW not working after kernel update to 5.5.3.
Fri, Feb 14, 11:46 PM · Hardware
Girtablulu closed T8532: Latest update broke my wifi as Resolved.
Fri, Feb 14, 11:31 PM · Upstream Issue, Hardware
Juankz added a comment to T8532: Latest update broke my wifi.

This got solved for me with the last update to kernel 5.5.3

Fri, Feb 14, 11:28 PM · Upstream Issue, Hardware
DataDrake moved T8728: enable CONFIG_NVME_HWMON in kernel from Backlog to Kernel Drivers on the Hardware board.
Fri, Feb 14, 10:39 PM · Hardware
DataDrake claimed T8728: enable CONFIG_NVME_HWMON in kernel.
Fri, Feb 14, 10:39 PM · Hardware
JoshStrobl added a comment to T4514: No sound with a ASUS E200HA.

Woohoo!

Fri, Feb 14, 5:10 PM · Hardware
Tearow added a comment to T4514: No sound with a ASUS E200HA.

It's good ! I have sound now thanks !

Fri, Feb 14, 5:03 PM · Hardware
Jacek added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

It would be great if you did. I know my sensor is supported by the kernel, because it works on Ubuntu out of the box.
Also I'm on unstable so I will test it when you rebuild the kernel.

Fri, Feb 14, 1:40 PM · Hardware
DataDrake added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

I can enable CONFIG_ACPI_ALS, CONFIG_HID_SENSOR_ALS, and CONFIG_HID_SENSOR_PROX which may cover a bunch of devices. But if it it's any of these specific devices, they'll need to be toggled on:

Fri, Feb 14, 12:54 PM · Hardware
crom5 added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

Asus G752VS laptop:

Fri, Feb 14, 8:18 AM · Hardware
Jacek added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

For my Toshiba Portege Z20t-b:

Fri, Feb 14, 7:41 AM · Hardware

Thu, Feb 13

crom5 added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

Lenovo Y700-17ISK laptop:

Thu, Feb 13, 4:12 PM · Hardware
feuerstein added a comment to T8061: PulseAudio Incorrect Microphone Volume.

Same, HDA-Intel - HDA Intel PCH

Thu, Feb 13, 4:02 PM · Hardware
feuerstein added a comment to T8532: Latest update broke my wifi.

I thought this is the latest kernel. After sudo eopkg check, this turned up:
`Checking integrity of udisks Broken
Corrupted file: /usr/lib/tmpfiles.d/udisks2.conf`
I doubt this is related but to be sure, how would I fix this?

Thu, Feb 13, 3:55 PM · Upstream Issue, Hardware
feuerstein added a comment to T8532: Latest update broke my wifi.

I ran a full update. The kernel according to hostnamectl | grep -i kernel is Linux 5.4.12-144.current.

Thu, Feb 13, 3:41 PM · Upstream Issue, Hardware
DataDrake added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

Try:

cat /sys/bus/i2c/devices/*/name
Thu, Feb 13, 3:33 PM · Hardware
JoshStrobl added a comment to T8532: Latest update broke my wifi.

@feuerstein That kernel is from early January. Update your system...

Thu, Feb 13, 3:22 PM · Upstream Issue, Hardware
crom5 added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

If anyone finds out what ambient light sensor they use, that'd be great.

Thu, Feb 13, 3:21 PM · Hardware
feuerstein added a comment to T8532: Latest update broke my wifi.

My wifi is also broken.
Kernel: 5.4.12-144.current
Device-2: Intel Wireless 8260 driver: iwlwifi

Thu, Feb 13, 2:57 PM · Upstream Issue, Hardware
DataDrake claimed T8721: Automatic brightness not avaiable on GNOME/Budgie.

Most likely the sensor isn't enabled in the kernel. This will take a fair bit of digging.

Thu, Feb 13, 2:47 PM · Hardware
crom5 added a comment to T8721: Automatic brightness not avaiable on GNOME/Budgie.

Wow, I didn't even know that in Linux it is possible to enjoy this important feature :)

Thu, Feb 13, 2:23 PM · Hardware
Jacek created T8721: Automatic brightness not avaiable on GNOME/Budgie.
Thu, Feb 13, 12:04 PM · Hardware
JoshStrobl closed T4514: No sound with a ASUS E200HA as Resolved.

Should be resolved with R349:1e6880b37e10: Update to 1.2.1.2, which you'll get this Friday. If your issue isn't resolved with the ALSA updates, feel free to re-open the task.

Thu, Feb 13, 5:05 AM · Hardware

Wed, Feb 12

Justin added a comment to T8715: Intel UHD 620 - GL Issues.

Well that fixed everything, Chrome, Vivaldi, Steam and GNOME-MPV playback..

Wed, Feb 12, 9:37 PM · Hardware
DataDrake closed T8547: CONFIG_ACPI_EC_DEBUGFS in kernel as Resolved by committing R3571:31706de5506f: Updated to 5.5.3.
Wed, Feb 12, 8:09 PM · Hardware
DataDrake closed T8703: Support for Solarflare network card as Resolved by committing R3571:31706de5506f: Updated to 5.5.3.
Wed, Feb 12, 8:09 PM · Hardware
DataDrake closed T8710: Kernel panic on shutdown related to NVME. as Resolved by committing R3571:31706de5506f: Updated to 5.5.3.
Wed, Feb 12, 8:09 PM · Hardware
Jacek created T8719: Make iio-sensor-proxy preinstalled on Budgie and Gnome.
Wed, Feb 12, 7:32 PM · Software
DataDrake added a comment to T8703: Support for Solarflare network card.

Looks like this was enabled in LTS, but not Mainline for some reason. Added it to linux-current for my current round of updates.

Wed, Feb 12, 6:57 PM · Hardware
DataDrake triaged T8715: Intel UHD 620 - GL Issues as Needs More Info priority.
Wed, Feb 12, 2:43 PM · Hardware

Mon, Feb 10

DataDrake triaged T8710: Kernel panic on shutdown related to NVME. as Normal priority.

Next time, let me assign it to myself. Thanks.

Mon, Feb 10, 8:30 PM · Hardware
ZVNexus assigned T8710: Kernel panic on shutdown related to NVME. to DataDrake.
Mon, Feb 10, 8:23 PM · Hardware
aquasp added a comment to T8701: VP09 youtube videos not loading correctly.

I think its a good idea to do the same until the bug is fixed,but is up to you. And yeah, I think it is a issue only with radeon mesa.

Mon, Feb 10, 7:26 PM · Hardware
alecbcs added a comment to T8061: PulseAudio Incorrect Microphone Volume.

I experienced this issue on both a Dell XPS 15 and 13 which have HDA-Intel integrated sound cards.

Mon, Feb 10, 5:17 PM · Hardware
joebonrichie added a comment to T8701: VP09 youtube videos not loading correctly.

Some more digging it seems to be a gstreamer-vaapi issue. There are two WIP patches to resolve it.
https://gitlab.freedesktop.org/gstreamer/gstreamer-vaapi/issues/136

Mon, Feb 10, 2:34 PM · Hardware

Sun, Feb 9

DataDrake moved T8703: Support for Solarflare network card from Backlog to Kernel Drivers on the Hardware board.

No problem.

Sun, Feb 9, 5:53 AM · Hardware
DataDrake claimed T8703: Support for Solarflare network card.
Sun, Feb 9, 5:52 AM · Hardware
aquasp added a comment to T8701: VP09 youtube videos not loading correctly.

Just more one question, is even possible that I installed some unnecessary libva that will cause some problems?

Sun, Feb 9, 2:29 AM · Hardware
aquasp claimed T8701: VP09 youtube videos not loading correctly.

I've seen this before, you need to disable allow_rgb10_configs in mesa.
Try this: https://github.com/ValveSoftware/steam-for-linux/issues/5434#issuecomment-379027036
I believe it's an issue with the chromium vaapi patch afaik which assumes rgba8.
There may be a way to only disable the dri conf in the brave application if it causes issues elsewhere.

Sun, Feb 9, 2:20 AM · Hardware

Sat, Feb 8

joebonrichie added a comment to T8701: VP09 youtube videos not loading correctly.

I've seen this before, you need to disable allow_rgb10_configs in mesa.

Sat, Feb 8, 10:22 PM · Hardware
DataDrake triaged T8701: VP09 youtube videos not loading correctly as Normal priority.

Then most likely, VP9 support isn't there yet for your GPU and by forcing on HW acceleration you are asking Brave to use a decoder which is not fully functional.

Sat, Feb 8, 8:38 PM · Hardware
ZVNexus added a comment to T8699: Laptop Frozen after Suspend.

Here's a full log of last boot and errors only.
https://del.dog/gekigainyf.txt
https://del.dog/fuqicicobi.txt

Sat, Feb 8, 8:12 PM · Hardware
livingsilver94 renamed T8700: Input lag after computer awakes from sleep mode with Linux 5.5.x from Input lag after computes awakes from sleep mode with Linux 5.5.x to Input lag after computer awakes from sleep mode with Linux 5.5.x.
Sat, Feb 8, 5:49 PM · Hardware
livingsilver94 renamed T8700: Input lag after computer awakes from sleep mode with Linux 5.5.x from I had to pass amdgpu.dc=1 with Linux 5.5.x to Input lag after computes awakes from sleep mode with Linux 5.5.x.
Sat, Feb 8, 5:49 PM · Hardware
livingsilver94 added a comment to T8700: Input lag after computer awakes from sleep mode with Linux 5.5.x.

Ah no, the delay is still here. It appears when my computer goes to sleep mode and wakes up, not my screen.

Sat, Feb 8, 5:14 PM · Hardware
DataDrake triaged T8699: Laptop Frozen after Suspend as Needs More Info priority.

Can you see what's in the systemd journal right after you start the shutdown? That should be getting flushed to disk before your lock-up.

Sat, Feb 8, 4:37 PM · Hardware
DataDrake triaged T8700: Input lag after computer awakes from sleep mode with Linux 5.5.x as Needs More Info priority.
Sat, Feb 8, 4:32 PM · Hardware
Xekko closed T8380: Line Out - Built-in Audio Disappears After Suspend as Resolved.
Sat, Feb 8, 12:35 PM · Hardware
Xekko added a comment to T8380: Line Out - Built-in Audio Disappears After Suspend.

Upon reading your comment, I tested Suspend and what do you know, Line Out Audio indeed now works again after waking the system! This is really great, I'm grateful that the issue is now fixed. joebonrichie, thanks for letting me know, as I've rarely tested/used Suspend due to becoming so used to this audio issue. I probably wouldn't have noticed for a long time that the issue had been fixed had you not commented about it.

Sat, Feb 8, 12:33 PM · Hardware

Fri, Feb 7

joebonrichie added a comment to T8380: Line Out - Built-in Audio Disappears After Suspend.

Is this still an issue for you? It's fixed for me personally by one of the recent kernel updates.

Fri, Feb 7, 1:59 PM · Hardware
DataDrake added a comment to T3147: OpenCL platform unavailable.

@Beer At this point, AMD OpenCL is only supported on the amdgpu-pro driver, which we don't support.

Fri, Feb 7, 1:35 PM · Hardware
Beer added a comment to T3147: OpenCL platform unavailable.

Can anyone clarify what the current situation is with this? I was trying to get davinci resolve running and hit a speed bump that I think is related to missing opencl driver (Vega64) and landed here.

Fri, Feb 7, 2:02 AM · Hardware

Thu, Feb 6

Hans38 added a comment to T83: Brother Drivers.

Hi, please add drivers to: Brother MFC-J6530DW
https://support.brother.com/g/b/downloadlist.aspx?c=nl&lang=nl&prod=mfcj6530dw_us_eu_as&os=128&flang=English

Thu, Feb 6, 3:44 PM · Hardware
denis added a comment to T8055: Solus breaks in hibernation.

Can everyone affected please confirm that they have a swap partition or a swapfile that is equal or larger than their RAM?

Thu, Feb 6, 11:56 AM · Hardware
alexdumi29 added a comment to T83: Brother Drivers.

Can you please add a driver for MFC-7420
Thank you and keep up the good work!

Thu, Feb 6, 6:41 AM · Hardware

Wed, Feb 5

mjc7806 added a comment to T83: Brother Drivers.

I would like to request drivers for the HL-L5100DN, please.

Wed, Feb 5, 11:31 PM · Hardware
DataDrake triaged T8646: Mic is nothing but static. (Even when not plugged in) as Needs More Info priority.

Can you check around in alsamixer (might need to install it) to see that your Mic isn't being muted or treated as an S/PDIF? Thanks!

Wed, Feb 5, 6:15 AM · Hardware
DataDrake triaged T8055: Solus breaks in hibernation as Needs More Info priority.

Can everyone affected please confirm that they have a swap partition or a swapfile that is equal or larger than their RAM?

Wed, Feb 5, 6:05 AM · Hardware
DataDrake triaged T8061: PulseAudio Incorrect Microphone Volume as Needs More Info priority.

Could you let us know what soundcards you have?

Wed, Feb 5, 6:04 AM · Hardware
DataDrake triaged T8308: Possible sleep solution for Thinkpad 13 2nd Gen as Needs More Info priority.

Usually something like this ends up getting fixed with a BIOS or kernel update. Have you checked for a BIOS update? Is this still an issue on the latest kernel?

Wed, Feb 5, 6:01 AM · Hardware
DataDrake moved T8547: CONFIG_ACPI_EC_DEBUGFS in kernel from Backlog to Kernel Drivers on the Hardware board.
Wed, Feb 5, 5:51 AM · Hardware
DataDrake claimed T8547: CONFIG_ACPI_EC_DEBUGFS in kernel.
Wed, Feb 5, 5:51 AM · Hardware
DataDrake claimed T8551: Tp link wn851nd wlan adapter.
Wed, Feb 5, 5:49 AM · Hardware
DataDrake triaged T8563: Sound not playing through headphones as Normal priority.
Wed, Feb 5, 5:49 AM · Hardware
DataDrake triaged T8621: Screen brightness act with delay since Friday Sync as Normal priority.
Wed, Feb 5, 5:34 AM · Hardware

Mon, Feb 3

Peter-S-31 added a comment to T83: Brother Drivers.

Can you add a driver for HL3170CDW? Thanks.

Mon, Feb 3, 10:00 PM · Hardware

Sun, Feb 2

erfly7 added a comment to T83: Brother Drivers.

PLEASE add support for MFC-7065DN print and scan

Sun, Feb 2, 6:01 PM · Hardware
DataDrake closed T5267: lost wifi connections Ralink 3290 as Resolved.
Sun, Feb 2, 4:43 PM · Hardware
DataDrake added a comment to T5267: lost wifi connections Ralink 3290.

It has been over a year since anyone last reported issues, if it is still a problem, please reopen to let me know. Thanks.

Sun, Feb 2, 4:43 PM · Hardware
DataDrake closed T5224: Bluetooth adapter stopped working after upgrade to 4.14 kernel as Resolved.
Sun, Feb 2, 4:43 PM · Hardware

Sat, Feb 1

solusme added projects to T8656: Freezes when using Krita: Low Hanging Fruit, Software, Hardware.
Sat, Feb 1, 10:49 PM · Software

Wed, Jan 29

mate-user added a comment to T3988: Broadcom driver isn't finding card.

@DataDrake that file shows an error when I open with Archive Manager, on my ThinkPad laptop with Solus 4.1 Mate.
Error:
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

Wed, Jan 29, 6:42 PM · Hardware
JoshStrobl added a comment to T4514: No sound with a ASUS E200HA.

@mickymow Merged your issue into this one as it may be related to outdated UCM files, which requires me to perform ALSA rebuilds. It's slated for Solus 4.2, hopefully I'll get it sorted in new few weeks. If the UCM updates don't resolve it you're kinda SOL, there' a bunch of issues related to the 98090 in the kernel bug tracker.

Wed, Jan 29, 5:41 PM · Hardware
JoshStrobl merged T8606: Bay Trail audio on Toshiba Chromebook 2 into T4514: No sound with a ASUS E200HA.
Wed, Jan 29, 5:40 PM · Hardware
JoshStrobl reopened T8532: Latest update broke my wifi as "Open".

@Juankz Please use this task for your wifi related issues rather than creating another one. Thanks.

Wed, Jan 29, 5:36 PM · Upstream Issue, Hardware