Page MenuHomeSolus

ffmpeg libvpx ABI mismatch
Closed, ResolvedPublic

Description

Issue

Attempting to use the system version of ffmpeg to encode to webm/vp9 target results in the following error:

[libvpx-vp9 @ 0x1a77b80] Failed to initialize encoder: ABI version mismatch

Repro

ffmpeg -i source.mp4 -y -an -vcodec libvpx-vp9 -filter:v scale=w=1200:h=480 -crf 2 -b:v 0 output.mp4

Encoding with a 4.4 static-build binary works fine with the above command.

Extra Context

Name: ffmpeg, version: 4.4, release: 110
Name: libvpx, version: 1.10.0, release: 13
scott@octagonal ~/playground $ ffmpeg
ffmpeg version 4.4 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 10 (Solus)
  configuration: --enable-avresample --enable-gcrypt --enable-gnutls --enable-gpl --enable-libaom --enable-libass --enable-libbluray --enable-libcdio --enable-libdav1d --enable-libdrm --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libglslang --enable-libmp3lame --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librav1e --enable-librubberband --enable-libsmbclient --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libtheora --enable-libtwolame --enable-libv4l2 --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --enable-libzimg --enable-nvdec --enable-nvenc --enable-openal --enable-opengl --enable-sdl2 --enable-shared --enable-version3 --enable-vulkan --disable-debug --disable-static --disable-stripping --libdir=/usr/lib64 --prefix=/usr

Event Timeline

This should be fixed with a rebuild of ffmpeg. Probably other revdeps of libvpx might be affected by this?

joebonrichie triaged this task as Normal priority.Aug 25 2021, 9:09 AM
joebonrichie edited projects, added Software; removed Lacks Project.
joebonrichie added a subscriber: joebonrichie.

The following packages have not been rebuilt against .13/.12 releases: avidemux, cinelerra-gg, ffmpeg, gstreamer-1.0-plugins-good, libopenglrecorder, qt5-webengine, vlc.

joebonrichie moved this task from Backlog to Package Fixes on the Software board.Aug 25 2021, 9:09 AM

gstreamer-1.0-plugins-good can be skipped, it was already rebuilt.

joebonrichie closed this task as Resolved.Aug 25 2021, 12:22 PM

Didn't rebuild qt5-webengine due to it killing my pc but a quick vp9 test in falkon shows no problems. Didn't rebuild cinelerra-gg due to build failure. I imagine ffmpeg should always have a safety rebuild in future after codec updates.

Just confirming the issue is resolved with today's update.

Thanks everyone!