Page MenuHomeSolus

virtualbox 6.1.20 (kernel 5.11.16-178.current) failure after 30 April 2021 update
Closed, ResolvedPublic

Description

Virtual machines will not start and fail with the following error:

Failed to open a session for the virtual machine <vmname>

The VM session was aborted.
Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
SessionMachine
Interface:
ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

dmesg shows the following error:

[May 1 16:52] vboxdrv: 00000000e8d0701f VMMR0.r0
[ +0.077948] vboxdrv: 00000000dfa56d76 VBoxDDR0.r0
[ +0.089305] EMT-0[3383]: segfault at 1 ip 00007fb46289d1b5 sp 00007fb4a8102818 error 6 in VBoxDD.so[7fb46279c000+170000]
[ +0.000012] Code: 5c 41 5d 41 5e 41 5f 5d c3 0f 1f 40 00 4d 8b 61 28 41 bd 07 39 00 00 ba ff ff ff ff 41 be 00 0f 00 00 4d 8b bc 24 b0 04 00 00 <41> c6 47 01 01 66 45 89 6f 02 41 8b 8c 24 b8 04 00 00 89 ce c1 ee

Event Timeline

appmath created this task.Sat, May 1, 10:54 PM
JoshStrobl added a subscriber: JoshStrobl.

Assigning to kyrios since he updated it last.

I think it's this issue, which is resolved in the latest 6.1.22 hotfix version.

@appmath I assume you are using an emulated LSI SAS controller with this VM?

kyrios123 added a comment.EditedSun, May 2, 8:41 AM

I am cooking VBox 6.22.
Hopefully not many users should be hit by this bug.

@kyrios123 I don't think LSI Logic controller is something that is used by default and it seems to me to that it is likely to be a pretty uncommon configuration. That's moreso why I was checking with @appmath to see if that's indeed what he is using (but it's very similar to the stacktrace from that bug report so I think it's likely).

I doubt we'll see more than a few additional people get bit by this bug before the next sync.

@ReillyBrogan Stop diving into basically every task. We have task triagers. Thanks.

kyrios123 closed this task as Resolved.Sun, May 2, 10:43 AM

Resolved by ffa6d1b11bc1

Fixed confirmed, thanks!

And yes my Windows vm was using the LSI - why, no idea, I set the vm up 5+ years ago.

Fix has now been cherry-picked to stable repo.