Page MenuHomeSolus

empty libraries
Closed, InvalidPublic

Description

so I was trying to open gnome-mpv and it wouldn't launch, but then I tried to launch it from terminal and I got error while loading shared libraries: /usr/lib64/libmpv.so.1: file too short

so for the heck of things, I ran ldconfig and I got the following issue

ldconfig: File /usr/lib/libopenmpt.so.0.2.2 is empty, not checked.
ldconfig: File /usr/lib/libswscale.so.5 is empty, not checked.
ldconfig: File /usr/lib/libvulkan.so is empty, not checked.
ldconfig: File /usr/lib/libswscale.so.5.9.100 is empty, not checked.
ldconfig: File /usr/lib/libmpv.so.1 is empty, not checked.
ldconfig: File /usr/lib/libavdevice.so is empty, not checked.
ldconfig: File /usr/lib/libavfilter.so.7.110.100 is empty, not checked.
ldconfig: File /usr/lib/libavformat.so.58.76.100 is empty, not checked.
ldconfig: File /usr/lib/libavfilter.so is empty, not checked.
ldconfig: File /usr/lib/libavcodec.so is empty, not checked.
ldconfig: File /usr/lib/libshaderc_shared.so.1.2021.0 is empty, not checked.
ldconfig: File /usr/lib/libavdevice.so.58 is empty, not checked.
ldconfig: File /usr/lib/libswscale.so is empty, not checked.
ldconfig: File /usr/lib/libavresample.so.4.0.0 is empty, not checked.
ldconfig: File /usr/lib/libheif.so.1 is empty, not checked.
ldconfig: File /usr/lib/libmpv.so.1.109.0 is empty, not checked.
ldconfig: File /usr/lib/libavcodec.so.58 is empty, not checked.
ldconfig: File /usr/lib/libswresample.so.3 is empty, not checked.
ldconfig: File /usr/lib/libavdevice.so.58.13.100 is empty, not checked.
ldconfig: File /usr/lib/libavutil.so.56.70.100 is empty, not checked.
ldconfig: File /usr/lib/libswresample.so is empty, not checked.
ldconfig: File /usr/lib/libpostproc.so is empty, not checked.
ldconfig: File /usr/lib/libavresample.so is empty, not checked.
ldconfig: File /usr/lib/libavformat.so.58 is empty, not checked.
ldconfig: File /usr/lib/libplacebo.so.120 is empty, not checked.
ldconfig: File /usr/lib/libopenmpt.so.0 is empty, not checked.
ldconfig: File /usr/lib/libvulkan.so.1.2.170 is empty, not checked.
ldconfig: File /usr/lib/libavcodec.so.58.134.100 is empty, not checked.
ldconfig: File /usr/lib/libavutil.so is empty, not checked.
ldconfig: File /usr/lib/libavfilter.so.7 is empty, not checked.
ldconfig: File /usr/lib/libavutil.so.56 is empty, not checked.
ldconfig: File /usr/lib/libswresample.so.3.9.100 is empty, not checked.
ldconfig: File /usr/lib/libpostproc.so.55.9.100 is empty, not checked.
ldconfig: File /usr/lib/libavresample.so.4 is empty, not checked.
ldconfig: File /usr/lib/libvulkan.so.1 is empty, not checked.
ldconfig: File /usr/lib/libheif.so.1.11.0 is empty, not checked.
ldconfig: File /usr/lib/libavformat.so is empty, not checked.
ldconfig: File /usr/lib/libpostproc.so.55 is empty, not checked.
ldconfig: File /usr/lib/libshaderc_shared.so.1 is empty, not checked.
ldconfig: /usr/lib/libwrap.so.0 is not a symbolic link

ldconfig: /usr/lib32/libwrap.so.0 is not a symbolic link

Normally I can solve some issues on my own, but this is actually something I never faced before and I'm at a loss about how to solve this.

Also this is a freshly updated system

Details

Differential Revisions
D10928: SPIR-V support for mpv

Event Timeline

ZachBacon updated the task description. (Show Details)Apr 26 2021, 2:23 AM

I would like to note that from discussions with Zach today that he is most likely using unstable right now.

Because of that this is very likely to be related to D10807. @aleksvor, @JoshStrobl, perhaps gnome-mpv needs a libplacebo rebuild as well?

aleksvor added a comment.EditedApr 26 2021, 7:10 AM

@ReillyBrogan can you reproduce this issue too?
About gnome-mpv - that's unlikely. gnome-mpv doesn't link to libplacebo directly, so rebuild is unlikely to help.

I would try to reinstall affected packages (mpv-libs, ffmpeg, shaderc, vulkan, libheif, libopenmpt, libplacebo) first, if Zach didn't try it yet. It looks like the files became corrupted somehow.

I have not been able to reproduce it myself. Gnome-mpv works fine for me. Perhaps he updated his system after libplacebo was updated but before mpv was finished rebuilding? The time he opened this issue doesn't really line up with that though...

I'm beginning to think it could of been an interrupt possibly but I'm not 100% sure, I essentially am doing right now is my own rebuilds on the eopkg's and reinstalling that way currently. Will report back when I can.

rebuilding the libraries did do the trick, but my guess is that somehow the installation must of gotten interrupted somehow. I really don't know how or why. But at least things are running again

JoshStrobl closed this task as Invalid.Apr 26 2021, 3:33 PM