Page MenuHomeSolus

Package Request: Waybar
Closed, ResolvedPublic

Description

Name: Waybar
Homepage: https://github.com/Alexays/Waybar
Why should this be in the Solus repo?: Waybar is a highly customizable Wayland bar for Sway and Wlroots based compositors. The repo currently has 'Swaybar' but 'Waybar' adds more functionality (think i3bar vs polybar). This would be a great bar to round out the Solus Sway experience (which is probably very underused yet actually quite good).
Is it open source: Yes - https://github.com/Alexays/Waybar/archive/refs/tags/0.9.7.tar.gz

Event Timeline

h3o created this task.Apr 25 2021, 6:18 PM

Solus doesn't use Wayland right now. Does this work in x11? I checked the the Arch and OpenSUSE packages and they both depend on Wayland so I'm assuming the answer is no.

h3o added a comment.Apr 25 2021, 9:13 PM

Hi Reilly, this wouldn't work in X11 but I am 95% sure (maybe less now) that I am running wayland in Solus via Sway and a tty login. When running Sway this way (vs through LightDM) I notice that Xorg is not running, and Wayland programs such as Sway and Wofi (installed from source) do run. I also have my Firefox running in a Wayland environment as confirmed on about:support. I'm not a tech person so could be missing the obvious here, but could swear I'm using Wayland right now lol

Note: "echo $WAYLAND_DISPLAY" also returns "wayland-0", if that means anything.

JoshStrobl triaged this task as Normal priority.Apr 25 2021, 11:16 PM
JoshStrobl moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
JoshStrobl closed this task as Wontfix.Aug 23 2021, 12:53 PM
JoshStrobl added a subscriber: JoshStrobl.

This has sat in accepted for inclusion for over 30 days. Clearly, there is a lack of demand for the inclusion of this software, nobody has stepped up to provide a completed patch, maintain it, and properly integrate it. Closing as a result. Feel free to reopen but only when someone offers a patch via our proper patch submission methods and volunteers to be maintainer.

h3o added a comment.Aug 30 2021, 10:32 PM

Thanks, @JoshStrobl.
I'd be interesting in learning to build, patch and maintain this but I wasn't able to find all dependencies in the Solus repos. Any ideas on how to proceed in these cases? I've listed the ones I couldn't find below:

Dependencies
chrono-date
libgirepository1.0-dev [gtk-layer-shell]
libpulse [Pulseaudio module]
libsndio [sndio module]

@h3o Only the first one would even merit a package request, but it's MIT and actively maintained, so have at it.

  • https://github.com/HowardHinnant/date (kinda suprised this isn't just vendored)
  • pkgconfig(gobject-introspection-1.0) aka gobject-introspection-devel
  • pkgconfig(libpulse) aka pulseaudio-devel
  • sndio-devel
h3o added a comment.Sep 1 2021, 4:13 AM

Thanks, @DataDrake!

Ok, so I packaged chrono-date using a local repository, but waybar was still failing to build. I was finally able to get a successful build after updating the following packages and moving them to the local repo:

  • fmt --> 8.0.1
  • libnl -->3.5.0
  • sndio --> 1.8.1
  • spdlog --> 1.9.2

Waybar built successfully after this, however I was unable to install to test due to the following error:

"System error. Program terminated.
External dependencies not satisfied: libstdc++ release >=58"

I actually get the same error when trying to install any of the packages in my local repo now. Hopefully just missing a basic step somewhere. Any thoughts on this? Thanks!

Harvey added a subscriber: Harvey.Sep 1 2021, 6:20 AM

External dependencies not satisfied: libstdc++ release >=58"

By default packages built through solbuild are built against the unstable repository. I assume your system is on "shannon" (stable) repository, so you will not have access to the updated gcc / libstc++

Note all packages submitted for inclusion in the Solus repository MUST be built against and tested on the unstable repository. Whether you move your system to unstable or do it in a virtual machine is up to you. Just know the unstable repository requires you to use IRC to check the topic of the #solus-dev channel before updating. https://getsol.us/articles/contributing/getting-involved/en/#irc updating when it says not to or "rebuilds in progress" etc, could result in a broken install.

h3o added a comment.Sep 1 2021, 2:38 PM

Thanks, @Harvey! That did the trick.

I'll look into next steps for submitting a package. I'll also need to submit chrono-date (in order for waybar to build properly), and some package updates for spdlog, fmt, sndio, and libnl. Apologies in advance if I mess anything up from here : )