Page MenuHomeSolus

IcedTea-Web
Closed, ResolvedPublic

Description

Name: IcedTea-Web
Homepage: http://icedtea.classpath.org/wiki/IcedTea-Web
Open Source: Yes
Source: http://icedtea.wildebeest.org/download/source/icedtea-web-1.6.2.tar.gz
Description: The IcedTea-Web project provides a Free Software web browser plugin running applets written in the Java programming language and an implementation of Java Web Start, originally based on the NetX project.

Related Objects

StatusAssignedTask
ResolvedDataDrake
ResolvedDataDrake

Event Timeline

rainer.brito updated the task description. (Show Details)Oct 4 2016, 12:27 PM
DataDrake updated the task description. (Show Details)Oct 4 2016, 3:14 PM
Justin added a subscriber: Justin.Oct 5 2016, 12:45 AM
DataDrake triaged this task as Low priority.Oct 8 2016, 4:46 AM
Seeder101 closed this task as a duplicate of T1126: IcedTea .Oct 17 2016, 4:29 PM
JoshStrobl reopened this task as Open.Oct 17 2016, 4:32 PM
JoshStrobl merged a task: T1126: IcedTea .
JoshStrobl changed the edit policy from "All Users" to "Triage Team (Project)".Oct 17 2016, 4:36 PM
Trillon008 added a comment.EditedDec 19 2016, 3:58 PM

I gave a quick look over this.
When trying to compil icedtea-web it requires a "mozilla-plugin" package.
From what I understand, after changing names many times this "package" or "headers" are now in NPAPI. Problem is: Chronium and Chrome are not using this anymore and Firefox plans to stop NPAPI soon.
https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Anyway didn't try with NPAPI headers yet but this could be a future problem, I'm not sure icedtea-web plan to evolve with the new API chrome et Firefox are using.

IcedTea also works stand-alone outside the browser to launch .jlnp files. I use it this way to access Cisco ASDM for administering ASA Firewalls as well as the remote console feature on SuperMicro servers.

IcedTea also works stand-alone outside the browser to launch .jlnp files. I use it this way to access Cisco ASDM for administering ASA Firewalls as well as the remote console feature on SuperMicro servers.

yes that's true that's why I use it for jlnp files for my uni they are using blackboard