Page MenuHomeSolus

Anki package missing dependencies
Open, NormalPublic

Description

The package anki from the repos is missing the dependencies distro and orjson. distro exists in the repos as python-distro, but orjson does not exist in the repos

Details

Event Timeline

moop created this task.Feb 26 2021, 1:09 PM
JoshStrobl triaged this task as Normal priority.
JoshStrobl edited projects, added Software; removed Lacks Project.
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.

@moop Thanks for the report! I'll get on it. Could you just tell me which function of Anki uses those deps, because I haven't run into any issues in my testing. Just so that I can improve my test plan.

algent added a subscriber: algent.Feb 26 2021, 9:09 PM

@Staudey you can simply run pip3 check. @moop did report the issue first in Solus forum: https://discuss.getsol.us/d/6417-anki-package-missing-python-dependencies

moop added a comment.EditedFeb 27 2021, 9:49 AM

@Staudey @algent Yeah, I didn't notice anything not working in the app, but I noticed the missing dependencies running pip3 check.