Page MenuHomeSolus

Black screen on boot after 23/01/2021 sync
Closed, InvalidPublic

Description

I already posted my issue in the community forum on the aggregated 5.10 issues thread, but I assume my post was forgotten. Thus I decided to raise this issue here so that it can be tracked properly. I apologize for the double posting!

Following last week's sync (on January 23), my laptop boots to a black screen and never reaches the greeter. I'm using both current kernel and current nvidia driver, with UEFI booth. Rebooting and switching to the previous kernel (5.10.7) with the bootloader allows me to login normally.

Below are my system specs (from running inxi -CG):

CPU:       Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP L2 cache: 4 MiB 
           Speed: 3500 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 3500 2: 3500 3: 3500 4: 3500 
Graphics:  Device-1: Intel HD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GM107M [GeForce GTX 950M] driver: nvidia v: 460.32.03 
           Device-3: Realtek Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: modesetting,nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 950M/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03

Here is the log (obtained by running sudo journalctl -b -e > journaltcl.log) from my latest failed boot:

Event Timeline

Since booting the previous kernel works it sounds like your nvidia-glx-driver package might not be fully updated?
Can you post the output of

eopkg info nvidia-glx-driver-current

I should have mentioned it in my original post, but I made absolutely sure everything is up-to-date. To confirm for nvidia-glx-driver-current, here is the info you requested:

Installed package:
Name                : nvidia-glx-driver-current, version: 460.32.03, release: 365
Summary             : NVIDIA Binary Driver (Current Kernel)
Description         : NVIDIA Binary Driver (Current Kernel)
Licenses            : EULA
Component           : kernel.drivers
Dependencies        : linux-current nvidia-glx-driver-common 
Distribution        : Solus, Dist. Release: 1
Architecture        : x86_64, Installed Size: 43.21 MB
Reverse Dependencies: 

Package found in Solus repository:
Name                : nvidia-glx-driver-current, version: 460.32.03, release: 365
Summary             : NVIDIA Binary Driver (Current Kernel)
Description         : NVIDIA Binary Driver (Current Kernel)
Licenses            : EULA
Component           : kernel.drivers
Dependencies        : linux-current nvidia-glx-driver-common 
Distribution        : Solus, Dist. Release: 1
Architecture        : x86_64, Installed Size: 43.21 MB, Package Size: 22.85 MB
Reverse Dependencies: 

nvidia-glx-driver-current package is not found in source repositories

@Staudey Any updates on this issue, given that the problem is quite critical?

Before doing any updates from this weeks' sync, I tried to install the LTS kernel as a backup. However, the LTS kernel (w/ corresponding nvidia-glx-driver installed) does not boot to a GUI either on my system. Installing the LTS kernel also seemed to mess with clr-boot-manager, which now always boots to the LTS kernel regardless of the default kernel listed by sudo clr-boot-manager list-kernels.

While trying to fix the default kernel boot options, I booted into a TTY on the 5.10.9 kernel and ran sudo clr-boot-manager update, which unfortunately deleted the 5.10.7 kernel (the only kernel which allowed me to boot to a GUI).

Since I then had nothing to loose, I tried fully updating my system, hoping that the new 5.10.11 kernel might boot to a GUI. Unfortunately, it doesn't work for me anymore than the 5.10.9 kernel does. I also tried rolling back my system to just before the 5.10.9 kernel update, but I wasn't able to because of some package having been removed from the repo (can't remember which one at the moment).

So basically, I'm now left with 4 kernels available (the 2 most recent of both current and lts branches), but not one of them can boot to a GUI. Since this is my only computer and Solus is my main OS, I'm in quite the predicament...

Any timely help to get this issue sorted would be greatly appreciated!

kaktuspalme added a subscriber: kaktuspalme.EditedJan 30 2021, 8:27 AM

Can you post /var/log/Xorg.0.log?

Edit: And maybe you can switch gpu configuration in bios/uefi settings. You could try there to disable the integrated gpu, maybe that would help.

@kaktuspalme Thanks for the help!

For good measure, I got the logs from both kernel branches, in case one issue might be easier to fix 😅

Xorg.0.log after trying to boot into current kernel.

Xorg.0.log after trying to boot into LTS kernel.

As for disabling the integrated GPU in the bios, I looked around but couldn't find any option for it. I think my laptop (Lenovo ThinkPad Edge 530) does not support this functionality and the dedicated GPU is rather a co-processor, where the integrated GPU is the only connected to the display and needs to be enabled for any display to the laptop's screen to work.

Why do you have nvidia-drm.modeset=1 in your kernel command line? I don't think that's standard (at least I don't have it).

One guy had a similar problem in the past with that parameter, see here: https://www.reddit.com/r/SolusProject/comments/a3bnrd/having_nvidiadrmmodeset1_kernel_parameter_set/

nathanpainchaud added a comment.EditedJan 30 2021, 7:55 PM

@Staudey The nvidia-drm.modeset=1 kernel is a standard solution to get rid of screen tearing issues on Nvidia Prime laptops, since they lack certain options in Nvidia's settings tool. See Harvey's survival guide post in the forums for reference. I've had this parameter set this way for as long as I've been using Solus (nearly 3 years now) and it's never caused me any issues before...

But I'll still try to disable it and see if it fixes my issue. Thanks for the reference!

Edit: Changing the parameter to nvidia-drm.modeset=0 still doesn't allow me to boot into a GUI with either of the kernel branches.

Edit2: I realized I forgot to run sudo clr-boot-manager update after changing the kernel parameter. After correctly updating the kernel parameters, I am able to boot to a GUI with the current kernel. This means that there is an issue with the modesetting with the last few releases of the current kernel branch. Thanks for the great help @Staudey !

Harvey added a subscriber: Harvey.Jan 31 2021, 3:06 AM

Thank you for reporting back. I've edited my survival guide post to alert nvidia prime users to the possibility of this occurring.

Pretty sure scotty_trees still uses this setting, so its not universal. I'll double check next time I speak to him.

JoshStrobl closed this task as Invalid.Feb 1 2021, 5:36 AM

Just reporting back. @Scotty_Trees confirmed the setting still works with a Nvidia MX150. So yeah confirmed not universal.