Page MenuHomeSolus

Can't use desktop if monitor is powered off or disconnected on kernel 5.10.4-165
Closed, InvalidPublic

Description

CPU: Intel i7-6700
GPU: XFX Radeon RX 570 connected to monitor via DisplayPort using amdgpu

Steps to reproduce: If running linux-current 5.10.4-165, turning off my monitor or disconnecting the DisplayPort cable I use results in me being unable to get anything to show up. My monitor does not even detect any video coming to it. Switching to a virtual terminal does not help and a full reboot appears to be required.

The issue does not occur after having downgraded to 5.10.2-164.

Event Timeline

Phantop created this task.Jan 1 2021, 9:27 PM
Phantop renamed this task from Can't use desktop if monitor is powered off or disconnected on 5.10.4-165 to Can't use desktop if monitor is powered off or disconnected on kernel 5.10.4-165.Jan 1 2021, 9:42 PM
Phantop updated the task description. (Show Details)
JoshStrobl closed this task as Invalid.Jan 1 2021, 10:52 PM
JoshStrobl edited projects, added Upstream Issue; removed Hardware.
JoshStrobl added a subscriber: JoshStrobl.

This is an upstream drm/amd issue, there are countless issues reported at https://gitlab.freedesktop.org/drm/amd/-/issues such as:

Marking as invalid because it's an upstream issue, not claiming the issue doesn't exist.