Page MenuHomeSolus

KWorld DVB-T 210SE
Open, NormalPublic

Description

I have the above TV tuner card and it does not register completely on my system.
The saa7134 module finds it and registers it as video0 (v4l2) but no dvb module gets loaded and as a result, it does not get registered as adapter0.

It is not officially supported but i can get it to work by using a modprobe conf file
alias char-major-81 videodev
alias char-major-81-0 saa7134
options saa7134 card=112 tuner=61 i2c_scan=1
install saa7134 /sbin/modprobe --ignore-install saa7134; /sbin/modprobe saa7134-alsa
options saa7134-alsa index=-1

Some relevant dmesg lines:
[ 4.207062] saa7134: saa7130/34: v4l2 driver version 0, 2, 17 loaded
[ 4.207340] saa7134: saa7133[0]: found at 0000:01:06.0, rev: 209, irq: 21, latency: 64, mmio: 0xfe4ff800
[ 4.207346] saa7134: saa7133[0]: subsystem: 17de:7253, board: ASUSTeK P7131 Hybrid [card=112,insmod option]
[ 4.207359] saa7134: saa7133[0]: board init: gpio is 100
[ 4.457948] saa7134: i2c eeprom 00: de 17 53 72 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
[ 4.457950] saa7134: i2c eeprom 10: ff ff ff 0f ff 20 ff ff ff ff ff ff ff ff ff 01
[ 4.457951] saa7134: i2c eeprom 20: 01 40 01 03 03 01 01 03 08 ff 00 fe ff ff ff ff
[ 4.457952] saa7134: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457953] saa7134: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 56 ff ff ff ff ff ff
[ 4.457954] saa7134: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457955] saa7134: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457956] saa7134: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457956] saa7134: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457957] saa7134: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457958] saa7134: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457959] saa7134: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457959] saa7134: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457960] saa7134: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457961] saa7134: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.457962] saa7134: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4.461946] saa7134: i2c scan: found device @ 0x10 [???]
[ 4.480945] saa7134: i2c scan: found device @ 0x96 [???]
[ 4.483946] saa7134: i2c scan: found device @ 0xa0 [eeprom]
[ 4.509955] tuner: 8-004b: Tuner -1 found with type(s) Radio TV.
[ 4.516946] tuner-simple 8-004b: creating new instance
[ 4.516948] tuner-simple 8-004b: type set to 61 (Tena TNF9533-D/IF/TNF9533-B/DF)
[ 4.529281] saa7134: saa7133[0]: registered device video0 [v4l2]
[ 4.529373] saa7134: saa7133[0]: registered device vbi0
[ 4.529396] saa7134: saa7133[0]: registered device radio0
[ 4.534934] saa7134_alsa: saa7134 ALSA driver for DMA sound loaded
[ 4.534970] saa7134_alsa: saa7133[0]/alsa: saa7133[0] at 0xfe4ff800 irq 21 registered as card -1

I have also attached a complete dmesg

I should note that it also needs 2 firmware files which are not included
dvb-fe-tda10045.fw
dvb-fe-tda10046.fw

In the past i was able to build the modules, copy the firmware files and it was working fine.

I can understand if you do not want to include the firmware files, this is not why i created the issue, i just mentioned it in case it helps.

Event Timeline

DataDrake triaged this task as Normal priority.Jan 10 2021, 4:53 PM
DataDrake edited projects, added Hardware; removed Lacks Project.
DataDrake moved this task from Backlog to Kernel Drivers on the Hardware board.
DataDrake added a subscriber: DataDrake.

Looks like we probably need CONFIG_VIDEO_SAA7134_DVB enabled in the kernel config.

Yes i am sorry, i tested it a while later and forgot to mention, enabling this config fixes the issue.