Page MenuHomeSolus

Gnome builder broken in 3.38, looks like glade package symlink issue
Closed, ResolvedPublic

Description

I installed gnome builder 3.38.1-60 and when trying to start it I get a missing library error for libgladeui-2.so.12:

$ gnome-builder 
gnome-builder: error while loading shared libraries: libgladeui-2.so.12: cannot open shared object file: No such file or directory

I am fully updated and in my system I see:

$ ls -l /usr/lib/libgladeui-*
lrwxrwxrwx 1 root root     22 Dec  5 16:01 /usr/lib/libgladeui-2.so.13 -> libgladeui-2.so.13.0.2
-rwxr-xr-x 1 root root 840184 Nov 23 22:29 /usr/lib/libgladeui-2.so.13.0.2

Creating a symlink /usr/lib/libgladeui-2.so.12 -> libgladeui-2.so.13.0.2 allows me to start gnome builder.

Not sure if this is a wrong dependency in gnome builder or if the glade package needs updating...