Page MenuHomeSolus

Gramps needs gexiv2 as a rundep, not just a builddep
Open, NormalPublic

Description

Just installed Gramps on a mostly-clean system. When I started it up, I got a big popup saying "GExiv2 Module Not Loaded" and gave me a link to instructions for building from source with that enabled. Installing gexiv2 makes that go away.

Gramps will work without gexiv2, but it won't have support for dealing with image metadata.

I looked in the package.yml here: https://dev.getsol.us/source/gramps/browse/master/package.yml and discovered that gexiv2 is listed in the builddeps, but not the rundeps. Sounds to me (having no idea why this might have been done if not by accident) like it should be a fairly easy thing to fix.

Event Timeline

hansk created this task.Nov 14 2020, 12:56 AM
DataDrake triaged this task as Normal priority.Nov 14 2020, 3:25 PM
DataDrake edited projects, added Software; removed Lacks Project.
DataDrake added a subscriber: DataDrake.

Yeah, I think I had to disable it at one point for compatibility issues.

DataDrake moved this task from Backlog to Package Fixes on the Software board.Nov 14 2020, 3:25 PM