Page MenuHomeSolus

Update fuse to 3.9.3
Closed, DuplicatePublic

Description

Update libfuse from 2.9.9 to 3.9.3
Why ? The switch is one that is really big and I cannot by any means tell everything that changed, you can check the changelog
-> API was extended both in normal fuse and low_fuse
-> Lots of bug fixes
There is a comprehensive changelog that shows the changes from 2.9.9 to 3x series right here

libfuse 3 is designed to be co-installable with libfuse 2. However, some files will be installed by both libfuse 2 and libfuse 3 (e.g. /etc/fuse.conf, the udev and init scripts, and the
mount.fuse(8) manpage). These files should be taken from libfuse 3. The format/content is guaranteed to remain backwards compatible with libfuse 2.

We recommend to ship libfuse2 and libfuse3 in three separate packages: a libfuse-common package that contains files shared by libfuse 2+3 (taken from the libfuse3 tarball), and libfuse2 and
libfuse3 packages that contain the shared library and helper programs for the respective version.

link to the GitHub repository
link to latest release tar file

Event Timeline

cata0309 created this task.Fri, Sep 11, 5:45 AM
JoshStrobl closed this task as a duplicate of T3023: fuse 3.Fri, Sep 11, 7:14 AM