Page MenuHomeSolus

Installer overwrites existing EFI partitions, cannot select different drive
Closed, InvalidPublic

Description

When installing Solus on a computer which already has an EFI partition, Solus installer insists on overwriting the current EFI partition and does not provide an option to install the EFI partition on another drive or to a different partition.

Additionally, Solus installer will install the EFI to a different drive than the one targeted for installation, even if the target drive is blank.

I ran into this when installing a second copy of Solus on a new, blank drive -- the Solus installer rewrote my EFI partition and I was no longer able to login to my previously-working OS. The installer does not present other options for EFI installation.

This causes two problems:

  • Existing EFI installations are destroyed or corrupted when Solus installs (windows, other linuxes)
  • Solus installation breaks if the drive containing the EFI partition is removed, even if Solus install drive is still present

Suggested fixes:

  • Solus should never overwrite an existing EFI partition
  • When installing "Automatically partition this empty disk and install a fresh copy of Solus.", Solus should install the EFI partition to that drive
  • If multiple drives are available, the installer may present an option to select other drives

Event Timeline

As you can see from these screenshots, even though I have selected /dev/sdc as the installation target, the installer forces me to overwrite my existing (Windows) boot loader on /dev/nvme0n1p2.

Framani added a subscriber: Framani.EditedAug 23 2020, 1:09 AM

I also had this issue before and what fixed it was to disable the existing EFI partition in gparted (remove flags) and enable the target EFI ( in the target drive). Once your new installation is done, enable the flags and it should work properly. You'll have to boot from uefi though in order to select the booting device. Good luck.

Thanks for the pointers, Framani. I found this guide also which mentions a similar (same?) process: https://discuss.getsol.us/d/1353-tips-for-dual-booting-solus-with-uefi I am attempting to do this now.

You'll have to boot from uefi though in order to select the booting device.

This is what I've been doing for the past year or so with Solus and Windows. I'm not aware of an easy alternative.

I believe the installer code is here? https://dev.getsol.us/source/os-installer/ The repo I found on GitHub seemed stale.

cbednarski renamed this task from Installer overwrites existing EFI partitions, breaking other operating systems to Installer overwrites existing EFI partitions, cannot select different drive.Aug 23 2020, 5:42 AM
cbednarski updated the task description. (Show Details)
JoshStrobl closed this task as Invalid.Oct 5 2020, 7:19 AM
JoshStrobl added a subscriber: JoshStrobl.

Duplicate of T2678 since you can't select the EFI bootloader install location.