Page MenuHomeSolus

Computer freezes
Closed, ResolvedPublic

Description

My computer freezes occasionally (about once or twice a month). It has been going on for quite a while (at least since September last year).

It usually happens when the computer is fairly idle, like when I'm reading a webpage.

When it happens the computer becomes completely unresponsive

  • keyboard and mouse does not respond
  • power button does not respond
  • can't switch tty with ctrl+alt+f1..f6
  • pressing caps lock does not turn on the caps lock led
  • magic sysrq does not work

The only thing I can do when it happens is to force a reboot (reset button or holding down the power button)

System information:

System:    Host: kim-solus Kernel: 5.6.19-158.current x86_64 bits: 64 Desktop: Gnome 3.36.4 Distro: Solus 4.1 
Machine:   Type: Desktop Mobo: ASRock model: X370 Gaming K4 serial: <superuser/root required> UEFI: American Megatrends 
           v: P5.10 date: 12/17/2018 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 1373 MHz min/max: 1550/3000 MHz Core speeds (MHz): 1: 1374 2: 1372 3: 1375 4: 1375 5: 1375 6: 1375 7: 1375 
           8: 1375 9: 1374 10: 1374 11: 1374 12: 1373 13: 1374 14: 1375 15: 1375 16: 1374 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu 
           v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,vesa resolution: 1: 1920x1080~60Hz 
           2: 1280x1024~60Hz 3: 1280x1024~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.36.0 5.6.19-158.current LLVM 9.0.1) v: 4.6 Mesa 20.1.4 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Device-3: Blue Microphones Yeti Stereo Microphone type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k5.6.19-158.current 
Network:   Device-1: Intel I211 Gigabit Network driver: igb 
           IF: enp31s0 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:3f:6c:c8 
Drives:    Local Storage: total: 13.65 TiB used: 7.69 TiB (56.4%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB size: 931.51 GiB 
           ID-2: /dev/sda vendor: Samsung model: SSD 840 EVO 500GB size: 465.76 GiB 
           ID-3: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
           ID-4: /dev/sdc vendor: Western Digital model: WD50EFRX-68MYMN1 size: 4.55 TiB 
           ID-5: /dev/sdd vendor: Western Digital model: WD80EFZX-68UW8N0 size: 7.28 TiB 
Partition: ID-1: / size: 911.73 GiB used: 322.70 GiB (35.4%) fs: ext4 dev: /dev/dm-2 
Swap:      ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%) dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 35.5 C mobo: 31.0 C gpu: amdgpu temp: 38 C 
           Fan Speeds (RPM): fan-1: 451 fan-2: 437 fan-3: 0 fan-4: 662 fan-5: 497 gpu: amdgpu fan: 807 
Info:      Processes: 343 Uptime: 36m Memory: 31.36 GiB used: 2.28 GiB (7.3%) Shell: fish inxi: 3.1.03

Output from journalctl for the last two freezes (both happened today):

I have tried:

  • re-installing Solus (twice)
  • two other cpus
  • another motherboard
  • other memory modules
  • probably a bunch of other things I forgot

The system is up to date, with the exception of today's updates that I haven't had time to install yet.

If more information is needed, let me know.

Event Timeline

I restarted from a Solus freeze a few minutes ago. I had opened 2 links in new tabs in Firefox, then it started glitching. I was able to move the cursor around, but Menu, Calendar didn't open. I had to hold the power button and forcefully shut down my laptop. This has been happening at least once a week for the last 2 months I think.
I feel like it might be a touchpad issue, I've noticed my touchpad isn't as responsive/accurate as before.

This happened to me a few days ago, while watching a movie on Amazon Prime Video in Firefox. Never happened before and hasn't happened since. The video froze and the audio stuck in a loop, replaying the same few seconds of audio repeatedly!!

I'm up-to-date with unstable repo and using Plasma as DE.

endumiuz added a comment.EditedSep 2 2020, 9:21 PM

It froze again today =(

Should I post the output of journalctl from when it happened or are the logs I already posted enough?
Is there something else I could do?

Edit: reworded the post

moriel5 added a subscriber: moriel5.EditedSep 23 2020, 10:45 PM

I can confirm that this is also happening to me, with a slight variation.
For me, it is only the graphics and keyboard input actions that freeze (I can toggle Num/Caps lock), on both my desktop and my laptop (recently upgraded with a new Barracuda Pro).
Additionally, the screen keeps flickering on Intel graphics.

Tested hardware, all fully functional, and no issues under other OSs.

Desktop:
CPU: i5-4670
GPU: Sapphire Radeon HD 6950
Motherboard: ASRock H97M
RAM: Crucial 4GB DDR3L@1600Mhz CL11 1.35V (manually changed, due to firmware insisting on defaulting to 1.5V)
HDD: 500GB Western Digital Blue 7200RPM
Firmware Payload: UEFI

Laptop:
Lenovo IdeaPad 300-15ISK
CPU: i5-6200U
GPU: Integrated
RAM: SK-Hynix 8GB DDR3L@1600Mhz CL11 1.35V
HDD: 1TB Seagate Barracuda Pro 7200RPM
Firmware Payload: UEFI

The latest mesalib did not change anything, so I am currently testing manually installing linux-current 5.7.10, and so far I have not seen of these issues.

moriel5 added a comment.EditedSep 23 2020, 11:16 PM

Update: I am now seeing these issues also on 5.7.10, though a lot less often than on 5.6.19.

moriel5 added a comment.EditedSep 24 2020, 5:16 PM

For whatever reason, I can set my laptop monitor's refresh rate to 120Hz when set below the native resolution, even though it's EDID does not list 120Hz as an option.
Could this perhaps be related?

Since changing the resolution, and restoring it, the issues appear to have disappeared, though I still need to test this.

JoshStrobl added a subscriber: JoshStrobl.EditedSep 24 2020, 5:46 PM

Update: I am now seeing these issues also on 5.7.10, though a lot less often than on 5.6.19.

We don't have the 5.7 kernel as our current kernel, so I have no idea what you're talking about. That was reverted clear back in July. Your issue is not related. The first issue by @endumiuz is a CPU soft lock, there isn't really any information on it, we'd need to see if it's resolved with newer kernels when we finally upgrade to that (blocked by NVMe issues). The second issue presented by @endumiuz is, at first glance, related to a bug in Dash to Dock extension for GNOME Shell, so I would suggest they ensure they're using the default settings since they shouldn't be getting any sort if "infinite recursion" issues.

Update: I am now seeing these issues also on 5.7.10, though a lot less often than on 5.6.19.

We don't have the 5.7 kernel as our current kernel, so I have no idea what you're talking about. That was reverted clear back in July. Your issue is not related. The first issue by @endumiuz is a CPU soft lock, there isn't really any information on it, we'd need to see if it's resolved with newer kernels when we finally upgrade to that (blocked by NVMe issues). The second issue presented by @endumiuz is, at first glance, related to a bug in Dash to Dock extension for GNOME Shell, so I would suggest they ensure they're using the default settings since they shouldn't be getting any sort if "infinite recursion" issues.

Sorry about that, I should have mentioned that I had to manually install the reverted package (no NVMe here, which is why I had no other issues). Originally I had thought that it might be due to something in the drivers, that was the reason for installing 5.7.

I still wonder whether I have a similar issue to @endemiuz's softlock issue, or if it is something completely different.
I shall upload my journal log when I'll be on Solus.

maybe try the -lts kernel? that worked for me: https://discuss.getsol.us/d/5518-can-t-run-away-from-freezes-forever/8

Perhaps, though currently the issues seem to have disappeared for me (back to latest "released" current kernel), and additional updates. so I'll continue to monitor the situation.

This comment was removed by JoshStrobl.

My freezes certainly have not returned, though now I have issues of a different sort (the PC freezing, outright crashing, and then rebooting), which I suspect are down to failing hardware (probably my dGPU, as no matter what I do, including cleaning the card, and replacing the thermal paste, it idles at ~70 degrees celsius, and rises to 80+ under extended load, though it could also be the board, since Asrock's 9-series boards are known to be unstable).

I had another freeze in the first week of September but haven't had any since.
I might have found one possible cause for the freezes, the power strip my computer was connected to was faulty and has now been replaced.

...The second issue presented by @endumiuz is, at first glance, related to a bug in Dash to Dock extension for GNOME Shell, so I would suggest they ensure they're using the default settings since they shouldn't be getting any sort if "infinite recursion" issues.

I have now restored Dash to Dock extension to the default settings.

I haven't had any freezes for months now so I guess this issue can be closed.

Girtablulu closed this task as Resolved.Feb 7 2021, 8:31 AM
Girtablulu claimed this task.