Page MenuHomeSolus

CHROMIUM
Closed, DuplicatePublic

Description

Requested Packages:
chromium
chromium-l10n

Homepage:
https://www.chromium.org/Home

Why: Chromium is the Open Source Basis of Chrome, Brave, Opera, Vivaldi, etc.

Open Source: yes.

References:

Archlinux repository
https://www.archlinux.org/packages/extra/x86_64/chromium/
https://www.archlinux.org/packages/extra/x86_64/chromium/download/

Debian repository
https://packages.debian.org/en/buster/chromium
https://packages.debian.org/en/buster/chromium-l10n

But PLEASE provide tar or gz-packages (or whatever), and NOT SNAP-packages because SNAP-packages use a lot more memory when installed.

Related Objects

Mentioned Here
T233: Chromium

Event Timeline

kyrios123 closed this task as a duplicate of T233: Chromium.Aug 21 2020, 5:50 AM

Would it be possible to install Chromium and keep it updated from the Archlinux repository?

https://www.archlinux.org/packages/extra/x86_64/chromium/
https://www.archlinux.org/packages/extra/x86_64/chromium/download/

What do i need to do in Solus for this? (package manager, repositories, etc.)

If yes, then please explain step-by-step (i am a total newbie...)

Jacek added a subscriber: Jacek.Aug 21 2020, 4:37 PM

You can't use AUR on Solus because they are completely different systems, and many instructions are different. You can sometimes use them as a guide for creating a package for Solus, but that is not necessary here.
So unfortunately there it seems they won't package Chromium for Solus because Google needs api key, so you have 3 options:

  1. Use Chrome
  2. Use chromium derivative like Vivaldi, Brave or Opera which are in the repos
  3. Install Chromium form Snap or Flatpak

That's clearly not ideal, but this is the reality of a project developed by a small team, you can't maintain everything.