Page MenuHomeSolus

autofs 5.1.6 crash
Closed, LockedPublic

Description

Updated my system and now autofs crashes:

Operation #135: upgrade
Date: 2020-05-26 09:01

  • autofs is upgraded from 5.1.3-3-1-x86_64 to 5.1.6-4-1-x86_64.

journalctl -xe

May 26 11:22:10 laptop systemd[1251]: tmp-autoytrnfo.mount: Succeeded.

May 26 11:22:10 laptop audit[2489]: ANOM_ABEND auid=4294967295 uid=0 gid=0 ses=4294967295 subj==unconfined pid=2489 comm="automount" exe="/usr/sbin/automount" sig=11 res=1
May 26 11:22:10 laptop kernel: automount[2489]: segfault at 0 ip 00007fd3968a234b sp 00007fffc0673630 error 4 in lookup_file.so[7fd396895000+1b000]
May 26 11:22:10 laptop kernel: Code: e8 5a 2d ff ff b8 01 00 00 00 e9 70 ff ff ff 41 54 55 48 89 f5 53 48 89 fb 48 89 f7 e8 ae fd ff ff 48 8b 15 d7 d6 01 00 89 c0 <48> 8b 12 4c 8b>
May 26 11:22:10 laptop systemd[1]: autofs.service: Main process exited, code=dumped, status=11/SEGV

May 26 11:22:10 laptop systemd[1]: autofs.service: Failed with result 'core-dump'.

May 26 11:22:10 laptop systemd[1]: Failed to start Automounts filesystems on demand.

Event Timeline

ops created this task.May 26 2020, 8:32 AM

Could you run automount in debug mode to see if you get more output ?

sudo su
systemctl stop autofs.service
automount -f -d
ops added a comment.May 26 2020, 5:10 PM

root@laptop ~ # automount -f -d
Starting automounter version 5.1.6, master map auto.master
using kernel protocol version 5.05
lookup_nss_read_master: reading master files auto.master
Segmentation fault (core dumped)

ops added a comment.May 26 2020, 5:14 PM

Last lines from

strace automount -f -d
openat(AT_FDCWD, "/etc/auto.master", O_RDONLY|O_CLOEXEC) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=817, ...}) = 0
read(4, "#\n# Sample auto.master file\n# Th"..., 4096) = 817
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=NULL} ---
+++ killed by SIGSEGV (core dumped) +++
Segmentation fault

Doesn't help much... :(
I guess we might eventually rollback

ops reopened this task as Open.May 29 2020, 3:58 PM

Operation #138: upgrade
Date: 2020-05-29 18:45

  • autofs is upgraded from 5.1.6-4-1-x86_64 to 5.1.3-5-1-x86_64 with delta.

Still crashes. Working version was 5.1.3-3-1-x86_64.

ops added a comment.May 29 2020, 5:23 PM

Removed autofs, removed my config files and reinstalled. Crashes with the default config.

kyrios123 removed kyrios123 as the assignee of this task.Jun 2 2020, 3:45 PM

Unassigned myself from this task or others might not look at it.

ops added a comment.Jun 7 2020, 12:33 PM

Did a fresh install on virtual machine. Crashes too.

Given it still segfaults with 5.1.3, I wonder if https://git.kernel.org/pub/scm/linux/storage/autofs/autofs.git/commit/?id=dbc5429a572bcbc72987f5f7944aa3f56fa25d88 on top of 5.1.6 would resolve the issue, since the referenced commit fixes a regression that wasn't fully resolved as of 5.1.3.

JoshStrobl closed this task as Resolved by committing R407:9ceb41e5c505: Update to 5.1.6.Thu, Jul 16, 12:38 PM
JoshStrobl claimed this task.
ops reopened this task as Open.Fri, Jul 17, 2:36 PM

Still crashing

Operation #56: upgrade
Date: 2020-07-17 17:07

    * autofs is upgraded from 5.1.3-5-1-x86_64 to 5.1.6-6-1-x86_64.
JoshStrobl closed this task as Wontfix.Fri, Jul 17, 3:02 PM

Please file your issue upstream with the autofs devs then

I just want to add: I did a few tests back in May, and rechecked yesterday:

  • autofs 5.1.3-3 as published initially (downloaded from https://packages.getsol.us/shannon/a/autofs/, no longer available) worked, and still works
  • autofs 5.1.3-3 re-built from the tag on current main crashes
  • 5.1.6-4, 5.1.3-5, 5.1.6-6 crash

My take from this is that the issue is from some static dependency update, not with autofs itself. I'm not sure how to investigate this further...

JoshStrobl changed the task status from Wontfix to Locked.Sun, Aug 2, 9:27 AM
This task has been locked.