Page MenuHomeSolus

simple scan saves corrupted PDFs after recent update
Closed, InvalidPublic

Description

After the recent update I can no longer save PDF documents from simple-scan. I believe the offending update (installed on 15th of May for me) was:

  • simple-scan is upgraded from 3.36.1-16-1-x86_64 to 3.36.2-18-1-x86_64.

I rolled back to before this update and it works fine. Upgrading again re-introduces the problem. The complete set of packages that were rolled back to fix the problem and then re-upgraded to reintroduce the problem is in the attached upgrade-after-rollback.txt

The problem is as follows:

  1. Scan a document
  2. Save the document
  3. Open the PDF

You will see that the content is garbled and illegible.

  1. Choose Print
  2. Choose Print to File
  3. Open the PDF that you printed (instead of saved)

You will see that the content is fine and legible.

So it seems like the scan succeeds but the operation to write to the PDF directly from the application somehow creates a broken file.

Event Timeline

karypid created this task.May 19 2020, 8:22 PM
algent added a subscriber: algent.May 19 2020, 8:59 PM

Your issue should be same as this one https://dev.getsol.us/T8987 which has been resolved by upgrading simple-scan to 3.36.2.1.
You can update to it next sync.

karypid closed this task as Invalid.May 19 2020, 9:42 PM

Yes that seems to be my problem (specifically part 2 of that).

I will close this and follow that one.