Page MenuHomeSolus

Gnome Display Manager Crashes When Attempting to Lock
Closed, ResolvedPublic

Description

After updating a fresh install of Solus Gnome, I can no longer lock the computer. After waking up from suspend, the system throws me back into my session without asking for a password. Attempting to manually lock the system results in Gnome crashing and rebooting the gdm session.

Here is a copy of the journalctl at the point of attempting to lock. Looks like a segfault in libst.

-- The job identifier is 209.
May 17 14:47:58 sudo[3477]:  alecbcs : TTY=pts/0 ; PWD=/home/alecbcs ; USER=root ; COMMAND=/usr/bin/journalctl -xe
May 17 14:47:58 sudo[3477]: pam_unix(sudo:session): session opened for user root by (uid=0)
May 17 14:48:13 audit[2646]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=1 subj==unconfined pid=2646 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=11 res=1
May 17 14:48:13 kernel: gnome-shell[2646]: segfault at 0 ip 00007fa98440be14 sp 00007ffcfe043840 error 4 in libst-1.0.so[7fa9843ec000+48000]
May 17 14:48:13 kernel: Code: 05 0f 84 97 00 00 00 48 83 eb 08 49 39 dc 0f 84 b2 01 00 00 48 8b 85 28 01 00 00 b9 0d 00 00 00 4c 89 ff 48 8b 14 18 48 8b 02 <>
May 17 14:48:13 gnome-session[1594]: gnome-session-binary[1594]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
May 17 14:48:13 polkitd[1000]: Unregistered Authentication Agent for unix-session:1 (system bus name :1.97, object path /org/freedesktop/PolicyKit1/Authentic>
May 17 14:48:13 gnome-session-binary[1594]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
May 17 14:48:13 gsd-media-keys[1802]: Couldn't lock screen: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus w>
May 17 14:48:13 /usr/lib64/gdm/gdm-x-session[1573]: (II) modeset(0): EDID vendor "AUO", prod id 23341
May 17 14:48:13 /usr/lib64/gdm/gdm-x-session[1573]: (II) modeset(0): Printing DDC gathered Modelines:
May 17 14:48:13 /usr/lib64/gdm/gdm-x-session[1573]: (II) modeset(0): Modeline "1920x1080"x0.0  142.60  1920 1978 2020 2080  1080 1083 1088 1142 +hsync -vsync>
May 17 14:48:13 /usr/lib64/gdm/gdm-x-session[1573]: (II) modeset(0): Modeline "1920x1080"x0.0  114.08  1920 1978 2020 2080  1080 1083 1088 1142 +hsync -vsync>
May 17 14:48:13 gsd-media-keys[1802]: Failed to grab accelerators: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface “org.gnome.Shell” >
May 17 14:48:13 gnome-shell[3484]: Unset XDG_SESSION_ID, getCurrentSessionProxy() called outside a user session. Asking logind directly.
May 17 14:48:13 gnome-shell[3484]: Will monitor session 1
May 17 14:48:13 dbus-daemon[1592]: [session uid=1000 pid=1592] Activating service name='org.freedesktop.portal.IBus' requested by ':1.118' (uid=1000 pid=3506>
May 17 14:48:13 dbus-daemon[1592]: [session uid=1000 pid=1592] Successfully activated service 'org.freedesktop.portal.IBus'

Event Timeline

alecbcs created this task.May 17 2020, 10:27 PM
alecbcs renamed this task from Gnome Display Manager Crashed When Attempting to Lock to Gnome Display Manager Crashes When Attempting to Lock.May 17 2020, 10:28 PM
JoshStrobl edited projects, added Upstream Issue; removed Lacks Project.
JoshStrobl added a subscriber: JoshStrobl.

Seems it may be an issue upstream. Even though we don't use gTile at all, I'm able to reproduce it however not able to reproduce any "fix" by disabling specific extensions, or all extensions. I'm going to see about merging https://gitlab.gnome.org/GNOME/gnome-shell/-/commit/d3934bd6854aa0b655437d443e59396dfb0c0945, which isn't in any of the latest releases, to see if that resolves the issue.

Okay so I did a sync with git, added a VT1 patch to GDM, and disabled all extensions. Still doesn't actually lock on suspend. I'm not getting anything related to segfaults anymore but it does make me question whether or not they're even calling to lock before suspending in the first place.

Regardless I'll push these commits and just reference this task (which isn't solved and doesn't seem to be Solus-specific, as others have reported it across Ubuntu and Fedora).

JoshStrobl triaged this task as Needs More Info priority.May 18 2020, 9:17 AM
JoshStrobl closed this task as Resolved.May 18 2020, 10:26 AM

Okay, for whatever reason I have budgie-desktop-branding-livecd still installed on my laptop, just not on my desktop. I'm guessing my issue was just caused by testing a bunch of stuff during prior GNOME stack upgrades and not doing proper cleanup on that system. That had a lock-enabled set to false which rightfully preventing it from locking. After uninstalling it, the issue is resolved. I'd double check that you also don't have this installed (you shouldn't but you never know). Marking this as resolved since I can now properly lock while suspending and there are no crashes.

alecbcs added a comment.EditedMay 19 2020, 5:10 AM

@JoshStrobl Thanks for your work on this fix! I can confirm that the latest patch in the unstable repository fixed the issue for me. Also I did not have budgie-desktop-branding-livecd installed on my system.