Page MenuHomeSolus

Audio crackles when using PulseEffects
Closed, ResolvedPublic

Description

When using Spotify or Discord with PulseEffects, the audio has noticeable crackling when eg. an application changes volume or plays a notification sound. This is worked around in Pulseaudio 13. PulseEffects already knows how to use the workaround, but as Solus is on 12.2, this needs to be applied https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/93 and also Pulseaudio should introduce itself as something else than 12.2 (PulseEffects detects either 13 or a - character to use the workaround).

Event Timeline

This is a long-standing bug that has been appearing and disappearing in time, on my system at least. If they found the cause and wrote a patch for it, I'm eager to see it applied.

DataDrake triaged this task as Normal priority.May 17 2020, 5:01 AM
DataDrake edited projects, added Software; removed Lacks Project.
DataDrake moved this task from Backlog to Package Fixes on the Software board.
stalebrim closed this task as Resolved.Jul 3 2020, 5:02 PM
stalebrim claimed this task.

Now that Pulseaudio got updated to 13.0 I can mark this as resolved. Thanks.

stalebrim reopened this task as Open.EditedWed, Jul 15, 11:40 AM

Reopening, as Pulseaudio got reverted back to 12.x

JoshStrobl closed this task as Invalid.Wed, Jul 15, 12:01 PM
JoshStrobl edited projects, added Upstream Issue; removed Software.
JoshStrobl added a subscriber: JoshStrobl.

Please, we don't need this re-opened. There's nothing we can do about this and it's clearly an upstream issue that is already resolved upstream, at the cost of other more serious issues.

stalebrim added a comment.EditedWed, Jul 15, 12:04 PM

There's nothing we can do about this

There is. Explained right in the first post. However, I can just build 13.0 myself like I've done so far. I just wished this could've been worked around which would benefit other people who use PulseEffects.