Page MenuHomeSolus

AMDGPU issue, screen flickering like crazy
Closed, InvalidPublic

Description

GPU: AMD RX 460

I have vanilla Solus installation, nothing tweaked. Three days ago my screen flickering was minimal. Today screen is flickering like crazy, I did update twice in that time. Is that what could caused the regression? Kernel upgrade?

I recorded the flickering with OBS, but in the final video there was no flickering. I tested the card with 3 different monitors, nothing changed. Taken out the GPU (only integrated intel HD) and flickering was gone. I put the same card in my older computer running Windows 8.1 and there is no flickering, so I assume the card is not defective.

Event Timeline

skmlcd created this task.Sep 29 2016, 1:26 PM
skmlcd updated the task description. (Show Details)Sep 29 2016, 1:28 PM
skmlcd added a comment.EditedSep 29 2016, 1:40 PM

Also tested with older AMD card that uses radeonsi driver (I think). Minimal flickering (normal I guess), not the same as with newer one that uses AMDGPU. So PCI-E slot / motherboard is not defective.

DataDrake added a subscriber: DataDrake.

Can you provide the output of "sudo lsmod"?

I suspect both the radeon and amdgpu modules may be getting loaded.

Module                  Size  Used by
fuse                   74442  3 
amdkfd                 62434  1 
amd_iommu_v2            6325  1 amdkfd
iTCO_wdt                5352  0 
iTCO_vendor_support     1985  1 iTCO_wdt
ppdev                   5768  0 
intel_rapl              8992  0 
amdgpu               1214321  4 
x86_pkg_temp_thermal     4512  0 
intel_powerclamp        7136  0 
coretemp                5512  0 
snd_hda_codec_realtek    51984  1 
i915                 1128609  2 
snd_hda_codec_generic    50452  1 snd_hda_codec_realtek
kvm_intel             164408  0 
psmouse                96184  0 
ttm                    67675  1 amdgpu
kvm                   425394  1 kvm_intel
evdev                  11136  9 
irqbypass               2737  1 kvm
snd_hda_codec_hdmi     29814  2 
i2c_algo_bit            5114  2 i915,amdgpu
serio_raw               4288  0 
drm_kms_helper         94501  2 i915,amdgpu
r8169                  60544  0 
syscopyarea             3198  1 drm_kms_helper
sysfillrect             3518  1 drm_kms_helper
sysimgblt               2367  1 drm_kms_helper
fb_sys_fops             1442  1 drm_kms_helper
snd_hda_intel          22720  7 
lpc_ich                14464  0 
mii                     4128  1 r8169
i2c_i801               11792  0 
drm                   270775  18 ttm,i915,drm_kms_helper,amdgpu
snd_hda_codec          83337  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           47558  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
thermal                 7648  0 
fan                     3584  0 
parport_pc             18057  0 
snd_hwdep               5294  1 snd_hda_codec
i2c_core               35657  6 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,amdgpu
snd_pcm                74396  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
parport                31988  2 ppdev,parport_pc
snd_timer              18766  1 snd_pcm
battery                 6736  0 
snd                    54416  22 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
mei_me                 17444  0 
soundcore               5388  1 snd
mei                    53167  1 mei_me
shpchp                 22399  0 
tpm_infineon            7320  0 
video                  24653  1 i915
tpm_tis                 9304  0 
button                  4326  1 i915
tpm                    28915  2 tpm_tis,tpm_infineon
sd_mod                 30226  3 
hid_generic             1280  0 
usbhid                 33644  0 
hid                    99092  2 hid_generic,usbhid
ahci                   26824  2 
libahci                20105  1 ahci
ehci_pci                3712  0 
ehci_hcd               40398  1 ehci_pci
xhci_pci                4288  0 
xhci_hcd              106609  1 xhci_pci
usbcore               159296  5 ehci_hcd,ehci_pci,usbhid,xhci_hcd,xhci_pci
usb_common              2286  1 usbcore

hmm ok. so it's only the amdgpu driver. No conflict there at least.

Are you running a high refresh rate monitor (>60Hz)? It seems there have been issues with the refresh rate being correctly identified in some cases:

https://bugs.freedesktop.org/show_bug.cgi?id=93826

skmlcd added a comment.EditedSep 29 2016, 2:14 PM

No, normal IPS 1920x1080 60Hz. And other monitors that I tried are the same, but NT panel. Tried both HDMI and DVI-D.

This is the video I recorded with my mobile phone.

skmlcd closed this task as Invalid.Nov 7 2016, 8:00 PM

I reinstalled the newest version of Solus. No longer seems to be the issue. It was probably a kernel regression or something similar. Closing, I will open a new issue (with more data) if the problem occurs again.