Page MenuHomeSolus

Compiz 0.8 full
Closed, InvalidPublic

Description

Hello,
I was part of support team and contributor to compiz. I truly like Solus, BUT not the cherry picking of plugins. ALL of the 0.8 plugins including experimental need to be included with the install with Mate. Let users decide which plugins they use, don't limit them because you find them useless.
Please include ALL 0.8+ plugins, Cube 3d Models being just one of them
Thanks

Event Timeline

coz_ created this task.Apr 11 2020, 3:18 PM
Jacek added a subscriber: Jacek.EditedApr 12 2020, 11:16 AM

Are you saying that compiz-plugins-extra package still doesn't include all the plugins you need?

Hello, Jacek,
Yes I am saying that. Here is a link of the missing plugins. https://www.dropbox.com/s/4u7ntxqw33cxmq2/ccsm.png?dl=0
Ones matked in blue are missing, ones in red I find necessary.
Part of my point is "Don't decide which plugins are worthy. Let users decide"
thanks

@coz_ please fill in a valid package request. ALL Compiz is not a package and anyway your request seems to be focused ONLY on the experimental plugins.

To be quite frank, I am still wondering if I should let this in: Offering experimental/unsupported plugins that may eventually lead stability issues on a system designed for everyone is perhaps not the best idea ever. Solus is a curated rolling release.

When upstream consider plugins are mature enough, they move it to -main or -extra. This is for instance the case with workspacenames that left experimental for extra in the latest release. Also Solus community hasn't shown much interest in experimental compiz plugins so far, I think this is the very first request.

On the other hand I know some people use a few experimental plugins and are happy with them and I know that most major distributions have this package in their repositories. Since I have no intention to default Compiz as window manager on MATE, I might eventually consider adding it.

JoshStrobl closed this task as Invalid.Apr 13 2020, 7:59 AM