Page MenuHomeSolus

Adding joplin to the repo's
Closed, DuplicatePublic

Description

https://joplinapp.org/

Joplin is a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks. The notes are searchable, can be copied, tagged and modified either from the applications directly or from your own text editor. The notes are in Markdown format.

Notes exported from Evernote via .enex files can be imported into Joplin, including the formatted content (which is converted to Markdown), resources (images, attachments, etc.) and complete metadata (geolocation, updated time, created time, etc.). Plain Markdown files can also be imported.

The notes can be synchronised with various cloud services including Nextcloud, Dropbox, OneDrive, WebDAV or the file system (for example with a network directory). When synchronising the notes, notebooks, tags and other metadata are saved to plain text files which can be easily inspected, backed up and moved around.

The application is available for Windows, Linux, macOS, Android and iOS (the terminal app also works on FreeBSD). A Web Clipper, to save web pages and screenshots from your browser, is also available for Firefox and Chrome.

Event Timeline

Bart2023 created this task.Apr 3 2020, 3:39 PM
Bart2023 renamed this task from Adding jopin to the repo's to Adding joplin to the repo's.Apr 3 2020, 3:40 PM
Bart2023 updated the task description. (Show Details)
Bart2023 edited projects, added Package Requests; removed Lacks Project.

What exactly is the difference between this and the other million note taking apps?

sethfl added subscribers: JoshStrobl, sethfl.EditedApr 3 2020, 5:34 PM

I love Joplin as well, but just download the appimage for now (or file a request on github for snap/flatpak support). This has also already been said by one of the lead devs:

Thank you for your feedback, it's been rejected per our package inclusion policy and my decision is final on the matter.

It has also been denied multiple other times (see T6488 and T8384).

And to respond to @EbonJaeger, there is no difference. The only "unique" thing about the app is it's UI. If you want a note taking app that can sync with cloud services and supports markdown that is already in the Solus repositories, see QOwnNotes and boostnote.

JoshStrobl closed this task as a duplicate of T6488: Joplin Integration.Apr 3 2020, 8:21 PM
mrdaltro added a subscriber: mrdaltro.EditedMay 15 2021, 9:28 AM

I love Joplin as well, but just download the appimage for now (or file a request on github for snap/flatpak support). This has also already been said by one of the lead devs:

Thank you for your feedback, it's been rejected per our package inclusion policy and my decision is final on the matter.

It has also been denied multiple other times (see T6488 and T8384).
And to respond to @EbonJaeger, there is no difference. The only "unique" thing about the app is it's UI. If you want a note taking app that can sync with cloud services and supports markdown that is already in the Solus repositories, see QOwnNotes and boostnote.

As far as I know, Joplin is the only note-taking app that have E2E (End-to-end) encrpytion feature (as well as Standard Notes, another great OSS project, that is not only E2E-encrypted, but fully data-encrypted). That is a "unique" thing and I think some users (specially those who need to, for some reason, deal with sensitive data) can actually beneficiate from an inclusion. Fortunately, the "official" way Joplin itself recommends to be installed is with a script that automatically downloads and installs the AppImage version on the system. Although we all know that "native" app would be clearly better, managed within eopkg.