Page MenuHomeSolus

There is a bug with launching snap applications
Open, Needs More InfoPublic

Description

There is a bug with launching snap applications
I have this error message:
snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Event Timeline

DataDrake triaged this task as Needs More Info priority.Mar 23 2020, 1:05 PM
DataDrake removed a project: Third Party Software.
DataDrake added a subscriber: DataDrake.

Can you please provide the output of systemctl status aa-lsm-hook?

Got this issue too. I solved it immediately by launching sudo aa-lsm-hook.
My output is:

● aa-lsm-hook.service - Load AppArmor profiles
     Loaded: loaded (/usr/lib/systemd/system/aa-lsm-hook.service; disabled; vendor preset: enabled)
     Active: inactive (dead) since Mon 2020-03-23 08:55:51 CET; 12h ago
    Process: 643 ExecStart=/usr/sbin/aa-lsm-hook (code=exited, status=0/SUCCESS)
   Main PID: 643 (code=exited, status=0/SUCCESS)

mar 23 08:55:51 phoenix systemd[1]: Starting Load AppArmor profiles...
mar 23 08:55:51 phoenix systemd[1]: aa-lsm-hook.service: Succeeded.
mar 23 08:55:51 phoenix systemd[1]: Started Load AppArmor profiles.
DrSheppard added a subscriber: DrSheppard.EditedApr 14 2021, 8:11 PM

Same error: cannot query current apparmor profile: Invalid argument

aa-lsm-hook.service - Load AppArmor profiles

  Loaded: loaded (/usr/lib/systemd/system/aa-lsm-hook.service; disabled; vendor preset: enabled)
  Active: inactive (dead) since Wed 2021-04-14 22:45:02 MSK; 28 min ago
 Process: 808 ExecStart=/usr/sbin/aa-lsm-hook (code=exited, status=0/SUCCESS)
Main PID: 808 (code=exited, status=0/SUCCESS)
CPU: 82ms

@DrSheppard Did you update recently from after having last updated in like March (or earlier)?