Page MenuHomeSolus

Intel 9260 Has Stopped Working
Closed, ResolvedPublic

Description

Hello, I had just upgraded my desktop to the ASRock H97M (alongside an i5-4570), and everything had been working smoothly, until I updated the OS (I haven't been at home for slightly over a month), after which both WiFi and Bluetooth stopped working (Intel 9260).
I could not search for wireless networks, nor could I enable/disable Bluetooth.

After downgrading the firmware, Bluetooth functionality was fully restored, even after returning the the latest firmware, however no change was seen with WiFi, regardless of the kernel version.

dmesg does not have any useful information, with the best being "Applying debug destination EXTERNAL DRAM" and "FW already configured (0) - re-configuring" (the last in bold).

Event Timeline

moriel5 created this task.Mar 13 2020, 1:03 PM

I saw some firmware updates in upstream git, trialing them locally..

moriel5 added a comment.EditedMar 13 2020, 1:06 PM

Thanks, I'll take a look at them.
Update: I do not see any firmware updates for the 9260, unfortunately.

moriel5 added a comment.EditedMar 14 2020, 10:39 PM

This is weird, but at least things appear to be working.

After updating my desktop (via ethernet to a network extender), things still were unchanged, however after selecting "connect to hidden network" and setting the connection again (I had already tried this on Friday), it not only connected (with the warning in dmesg "associating with AP with corrupt probe response"), but starting from that point, my Intel 9260 is able to find wireless networks again (and yes, it was even unable to find a non-hidden hotspot from my phone being half a meter away before that point).

I'll test if things persist after reboot.

Update: Thankfully, everything seems to be working after rebooting, though the dmesg warnings still appear.

moriel5 closed this task as Resolved.Mar 14 2020, 11:16 PM