Page MenuHomeSolus

Freezes when using Krita
Closed, ResolvedPublic

Description

Hi guys.

Can you help me with this issue?

I am on Solus Budgie. I'm using it from more than 2 years. It is great and love it.

But recently I'm experiencing constant freezes after the last updates. I should have done a few history packages back to test for the problem, but I did instead a fresh install and now I lost the update history. So I can't tell for sure, is it from the new Solus 4.1 with the new kernel or from which specific update in row. I had no problems with Solus 4.0 The problem occurred this month.

The freeze happens while I'm using Krita. I draw a lot. I'm using Krita to draw for work. I'm using an appimage of Krita from very long time without problems. But now the system stuck. I've tried and installed Krita from the repository. The freeze happens again and with this option.

Only restart from the PC button is the remedy.

I can't reproduce the issue in steps. It is random. Sometimes when krita autosaves, sometimes when I'm deforming image, sometimes when just drawing or drag an image. Usually it is a full freeze with mouse and keyboard halt, but some times mouse is active. I managed once while in freeze to enter the Console with CTRL+ALT+F2. It appeared to work fine, but I'm not so advanced linux user to know what to do in this mode, so when got back to the graphic environment, it was still stuck screen.

I think it happened and 2 times when I was using Blender.

I don't have the issue with other programs or other use of Souls so far.

I understand that the problem could be everything, but still... any ideas?

Thanks and
Best Regards

P.S.:
Tomorrow, I'm gonna test drawing with an old version of Solus on USB that I have. And perhaps with different linux distro, just for measure.


OK, the result update:

I've been drawing all day long with Krita appimage under live USB of Solus Plasma - the test version that was Solus 4.0 with kernel 4.20.16-112. No freezing issues with it, except that Krita crashed on me once. There were no problems during the rest of the time.

Event Timeline

solusme created this task.Jan 29 2020, 11:43 PM
Jacek added a subscriber: Jacek.Jan 30 2020, 8:55 PM

So do you get problems with both Appimage and version from the repos?
What CPU and GPU are you running? New kernel/systemd might cause problems with your hardware.
Things you can try doing:

  1. Do sudo eopkg check and see if any packages are broken (udisks will report as broken, but what about everything else?)
  2. Check system monitor or htop if you have any SWAP - maybe the new installation didn't give you any, and this would for sure cause problems with photo editing or 3D modelling
  3. Try older Krita by using older Appimage - this might be tedious, as the stalls are random
  4. Just to be sure, are you sure you are not overclocked? Maybe it crashes while using Krita and Blender because they are the only programs pushing your system to the limit, and it isn't stable. Memtest or any stress test might be a good idea.
solusme updated the task description. (Show Details)Jan 30 2020, 11:50 PM

Giving answers as it fallows:

Yep, I'm experiencing the same issue under Solus 4.1 Budgie with both Krita appimage 4.1.7, appimage 4.2.8 and also with the version 4.2.8 from the repo.

The CPU is Intel Core i3-8100 3.60GHz × 4
No GPU currently

The packages check said everything is OK, except the mentioned from you (udisks - Broken and Corrupted file: /usr/lib/tmpfiles.d/udisks2.conf)
I'm keeping my system clean from too many programs, the only fancy programs that I have are Blender and Krita.

I assigned a SWAP partition during the new installation 8GB as my RAM is 8GB. 'Disks' says that there is one and it is active.

I am actually using Krita 4.1.7 on daily basis. It seems to be more light than 4.2.8. So I'm using older version.

I never do overclocks to my CPUs :)

I agree It could be stressful for the system and the CPU, specially without having GPU, but Like I said I'm using Solus in about two years and I'm drawing with Krita from the same time. Never had that issue until about a month. Could it be the new kernel, like you said?

Can you supply a guide how to downgrade the kernel correctly to the previous one used by Solus? I would like to test. My 'Home' folder and my data are on separate partitions, so it won't be a problem to try. If something gets wrong, I'll do a clean install.

Jacek added a comment.Jan 31 2020, 8:35 AM

I don't know how you could do that, somebody from the core team would need to help you with that. Best way I can think of is to run that AppImage off of Solus 4.0 LiveUSB, or just installing Solus 4.0 and not updating it. Trying on any other distro with new kernel could also point in the right direction.
Again you could do a Memtest, stresstest and check if you are not running out of RAM before crashing.

Yep, yep, the test with Solus 4.0 LiveUSB and the appimage was already done. It works fine! :) I did it yesterday with Solus 4.0 Plasma
Yeah, instead of downgrading of the kernel, I think, it would be better if I can find a Solus 4.0 Budgie and do gradually updates and testing to see after which update the crash happens. That will narrow down the causes.

For the mem, stress and RAM tests I have tools for windows, but I have to install windows for that purpose.
I'm not familiar with the test tools under Linux. I have to check what is available.

OK! Thanks for the direction ideas and guidance.
Best Regards!

OK
I did some new tests. The issue could be from the new kernel.

I did a new instal with .iso of Solus 4.0
It is interesting that during the gradual updates it updated first the OS, so Solus was upgrated to 4.1 Fortitude and the kernel was still 4.20.16-112. I did a couple of hours drawing. No problem. After a couple of more updates at some point the kernel was changed to 5.4.12-144.

The cool thing was that GRUB made 2 instances of starting Solus 4.1 Fortitude: one with kernel 5.4.12-144 and one with kernel 4.20.16-112. So with kernel 5.4.12-144 and a couple of more hours drawing it continued to freeze, with kernel 4.20.16-112 there were no problems.

In my opinion this is not from the Solus it is from the linux kernel. I need to find out what is changed with 5.4.12-144 in comparison to 4.20.16-112 that concerns RAM, CPU performance and graphics.

I found also during the updates --> intel-microcode 20191115-11-1-x86_64 install. This could create issues also in its place and perhaps the kernel could be fine.

JoshStrobl renamed this task from Budgie consistently freezes while using Krita to Freezes when using Krita.Feb 1 2020, 10:51 PM

OK,
After a couple of days of testing I can definitely say that my issue is coming from the new kernel 5.4.12-144.

What I did was updating everything in a clean Solus install except for the updates that I thought could be problematic. In my case:

linux-current <-- this one upgrades krenel from 4.20.16-112 to 5.4.12-144
linux-firmware <-- this one intel-microcode
xorg-driver-video-intel <-- this one intel video driver

So I did a long day test installing every each one individually, drawing, then removing it, then installing the next one...
Starting with the video driver first, then the microcode - no problems with these.

And the last, the kernel - Bam! What I expected. Instant freeze.
I think I met also, somewhere in the forums, a report with a complain - after the last updates when copying large files from one partition to other the mouse hiccups or freezes for moments. I've tried that also. Confirmed - it is happening. This could be related.

The strange thing is that I didn't notice any abnormal CPU or RAM behavior.

What could be the cause of this issue?

Meanwhile I'll downgrade to 4.20.16, because it works light and smooth.

Jacek added a comment.Feb 4 2020, 4:08 PM

There is 5.5 kernel in unstable already, so it will probably come with friday sync. But updating might be tricky for you, as Solus only keeps 2 kernels, so if you update you will be stuck with 5.4 and 5.5.
It might fix your problems. Also have stutters of different king, the interface (task bar, avaiable networks, volume controll) hangs, I hope this will get fixes too.

DataDrake triaged this task as Needs More Info priority.Feb 5 2020, 6:12 AM
DataDrake added a subscriber: DataDrake.

Please let me know the status of this following the kernel 5.5.1 upgrade later this week. Thanks!

No problem Jacek. I keep approximately clean and simple linux install. Plus those programs that I use in appimages. So, If something goes wrong with 5.5, I can easily reinstall the system with the old kernel. Thanks.

Ok, I'll test 5.5.1 at Saturday. Thanks DataDrake.

OK, I've been testing since the last update of the kernel to 5.5.3-147, torturing Krita and Blender two days long. :)

No issues at all! Everything seems fine. I'm so happy.

Thanks for the great support!

My Best Regards.

solusme closed this task as Resolved.Feb 19 2020, 10:42 PM