Page MenuHomeSolus

Copy/paste issues
Closed, WontfixPublic

Description

Sometimes when cutting or copying text in LibreOffice Writer and then trying to paste it somewhere (be it in Writer itself or anywhere else) i get previous text i copied and not the current, then i need to repeat the action again.
I don't think i noticed that behavior when doing work not involving LibreOffice, but another user in the forums (https://discuss.getsol.us/d/3546-clipboard-issue/2) mentioned that it also happens when working with Master Pdf Editor.

I use Solus Budgie. I don't really know how to reproduce this issue yet. It occurs at seemingly random moments. I noticed that the issue continues to occur about few months ago but i might have had it since the installation in summer of 2019. I don't remember having this problem when using Solus Mate before though.

Event Timeline

DNI_R created this task.Jan 29 2020, 8:37 AM
DataDrake edited projects, added Software; removed Lacks Project.Jan 29 2020, 11:09 AM
DataDrake added a subscriber: DataDrake.

I have not been able to reproduce this.

I have this issue since Autumn 2019, in WPS office suite. Since WPS is third-party, I didn't raise this issue. Today I tried in LibreOffice, have the same issue.

I'm also experiencing this. After digging a bit I've found this thread, which seems to suggest the problem may be related to Mutter.

Lorien added a subscriber: Lorien.Feb 1 2020, 6:03 PM
DataDrake triaged this task as Needs More Info priority.Feb 5 2020, 6:13 AM

Marking as needs more info since someone on our side will need to dig into it.

DNI_R added a comment.EditedFeb 5 2020, 8:45 AM

That's probably not much, but i can share more of my findings with this issue.
So the way i reproduce it is very simple. I write some words in Libre Office (since i haven't notice this behavior anywhere else) and then simply try to copy/paste them one by one with ctrl-c, ctrl-v keystrokes in the same document until i get the previous selection pasted and not the current. It might take some time till it occurs, like the most recent time it took 24 times of copying words till it happened.

Another thing that i have not noticed before is the issues with copying using only the right click menu. With the right click menu copying fails almost every second time and when it fails the output is most of the time blank - there is no previous selection pasted like with keystrokes. Though rarely i do get previous selection pasted too instead of blank output, so that is not consistent behavior unlike with keystrokes.

In the forums there was a suggestion to try inspecting this issue with xclip , using commands xclip -o -sel primary and xclip -o -sel clipboad for different clipboards. When copying fails i get an error Error: target STRING not available with both methods.
Also with keystrokes i only get a correct output with clipboard, with primary i get the same error Error: target STRING not available every time. And with right click menu i get correct output with both clipboard and primary if the copying is successful.

JoshStrobl closed this task as Wontfix.Mar 19 2020, 3:20 PM
JoshStrobl edited projects, added Upstream Issue; removed Software.
JoshStrobl added a subscriber: JoshStrobl.

This is an upstream issue in Mutter: https://gitlab.gnome.org/GNOME/mutter/issues/1113