Page MenuHomeSolus

Minigalaxy package addition request
Closed, ResolvedPublic

Description

minigalaxy

https://github.com/sharkwouter/minigalaxy

Lutris can provide a similar function but it is substantially more complex than what minigalaxy offers. Minigalaxy is in it's infancy but at this point seems to be functional and I think it would make a great addition to the already superb lineup of gaming tools and clients on Solus.

It is open source under the GNU General Public License Version 3

I think it will get a good/large audience if it is well known by the Solus gaming community, as the official GOG client has yet to come to linux. I think (if it works well that is) it would get a good amount of users as a GOG client seems to be on the wishlist of a lot of Linux users in general. Granted we are a smaller community when compared to say Ubuntu, But I believe the Solus gaming community would be a quick adopter of minigalaxy, that is for those that are in the cross-over of "I use Solus and GOG.com".

https://github.com/sharkwouter/minigalaxy/archive/0.9.1.tar.gz

Event Timeline

V1T4MiN created this task.Dec 30 2019, 2:27 PM
JoshStrobl triaged this task as Normal priority.Dec 30 2019, 9:31 PM
JoshStrobl moved this task from Backlog to Accepted For Inclusion on the Package Requests board.

May I step in, I've succeed in building the package, but when I try to login python back-trace shows me:

requests.exceptions.ConnectionError: HTTPSConnectionPool(host='embed.gog.com', port=443): Max retries exceeded with url: /account/getFilteredProducts?mediaType=1&page=104 (Caused by NewConnectionError('<urllib3.connection.VerifiedHTTPSConnection object at 0x7f188b3b5320>: Failed to establish a new connection: [Errno -2] Name or service not known',))

IDK why, as I could login correctly via browser, still I'm totally clueless as other distros can perfectly run the software.

Yeah, It's reachable from firefox.

Harvey added a subscriber: Harvey.Jan 1 2020, 10:45 PM

I built the package just then and I can login fine. However its very early days for this project, if you want to maintain this I suggest waiting for version 1.0.0

There is some pretty basic functionality that is not in 0.9.1 I think most users would expect to just work such as:

  • Uninstalling games
  • Updating games
  • Offline mode
  • Changing the installation directory makes minigalaxy unable to detect previously installed games
  • Games not detected if their installation folder isn't their exact title

Most of these issues a slated to be fixed in 1.0.0 https://github.com/sharkwouter/minigalaxy/milestone/1

@Harvey most of those issues appear to have been fixed in release 0.9.2 actually and since there's an AUR package with a PKGBUILD (which are quite similar to package.yml) it should be pretty easy to maintain. I'll give packaging it a crack myself and submit a patch if it works out.

Hopefully you'll be happy to hear I submitted a patch for v0.9.2 D8363 :D

algent added a subscriber: algent.Mon, Mar 16, 6:25 PM

This task can be closed. Resolved by 5d3eb7c6fecb

Girtablulu closed this task as Resolved.Mon, Mar 16, 6:40 PM
Girtablulu claimed this task.