Page MenuHomeSolus

Solus randomly crashes - Ubuntu runs stable on same machine
Closed, ResolvedPublic

Description

Hi everyone, hope this is the right place for this, apologies if it isn't.

I'm having a huge problem with Solus. The complete OS crashes/freezes randomly. When that happens, the sound stops playing, the mouse cursor doesn't move, and input is not recognized. After ~half a minute, the PC reboots automatically.

This usually occurs within one hour of uptime (regardless of loads), but i've also had it occur right after booting up Solus and just opening the Raven sidebar (so the system froze within seconds of uptime). Sometimes, everything seems fine, i do some work in Solus, the machine is under load but no freeze, then all of a sudden i just open Nautilus or Software Center and it crashes again. Most of the crashes occured during installations via the software center, but other times it just crashed during browsing or other 'casual' works.

The same PC is running fine with Ubuntu 16.04 (Kernel 4.7.x). Within Ubuntu, I did some stress testing with the CPU (all four cores where at 100% load). Also tested with GPU full load at the same time. I also tested memory using memtester. I can't reproduce this crash/freeze error in Ubuntu no matter what i try. Under rare circumstances, Ubuntu might freeze too, but those are corner-case bugs (vaapi video playback fails), whereas Solus just freezes randomly no matter what. I can work for days without issues in Ubuntu, while Solus does not run stable even for one hour :(

I have two partitions on the SSD, one with Ubuntu (installed first) and a second partition with Solus (installed after installing Ubuntu). Let me know which logs or other information you need and i'll provide those. Thanks in advance for looking into this problem!

Event Timeline

suloS created this task.Sep 25 2016, 1:51 PM
suloS added a comment.Sep 25 2016, 8:34 PM

Thanks to ikey and datadrake the problem is already fixed - the problem was with the microcode of the specific cpu, after updating the microcode through a bios update solus is now stable! Thanks again for helping me figuring this out, this can now get closed.

DataDrake closed this task as Resolved.Sep 25 2016, 8:36 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

I think we have this mostly resolved, per our conversation in IRC. It seems to have been an out of date microcode provided by your BIOS and updating the bios resolved it. I'm going to close this for now. But if you have further issues we can reopen it and continue troubleshooting.

For the record this was with a Boardwell "ix-xxxxC" part.