Page MenuHomeSolus

KDevelop
Closed, ResolvedPublic

Description

KDevelop is a cross-platform IDE for C/C++ and many other programming languages

Name: KDevelop
Website: https://www.kdevelop.org/
Open source: Yes
Source code: http://download.kde.org/stable/kdevelop/5.0.0/src/

Event Timeline

mladen created this task.Sep 25 2016, 10:38 AM

Why KDevelop over the other IDE's in Solus?

No particular reason, I receantly started learning python and find it very good IDE and thought it would be nice addition to the Solus repo

Given our existing choice, we need legitimate reasons for inclusion. Unique and useful features (not niche ones) for instance, plus it needs to be using KDE Frameworks 5.

One thing that I can think of is it can show details of a problem in the source code and offer solutions. Latest version is using KDE Frameworks 5 as far as I know. Anyway they provide download in AppImage format, so it's not a big deal.

JoshStrobl closed this task as Wontfix.Oct 28 2016, 7:15 PM
JoshStrobl claimed this task.
usillos added a subscriber: usillos.
ikey reopened this task as Open.Apr 18 2017, 5:09 PM
ikey claimed this task.
ikey added a subscriber: ikey.

Reopening. This bug was filed prior to having a proper package inclusion policy. I'll package this myself.

DataDrake triaged this task as Normal priority.Apr 18 2017, 11:54 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
sunnyflunk closed this task as Resolved.Apr 19 2017, 6:35 AM

I stole this cause I had some deps prepared. Now included in unstable for testing https://git.solus-project.com/packages/kdevelop/commit/?id=48e82d466bbc2a7584de6529723709a5b1a0fa2c

Could you add the python plugin to it?
See https://community.kde.org/KDevelop/HowToCompile_v5#2._Get_and_install_plugins_.28optional.29
Note: there's also a php plugin.

Also, I found it strange that the package installed subversion as a dependency, but maybe that was intended.
If not, it can be removed as described here: https://github.com/KDE/kdevelop#optional-dependencies

Could you add the python plugin to it?
See https://community.kde.org/KDevelop/HowToCompile_v5#2._Get_and_install_plugins_.28optional.29
Note: there's also a php plugin.
Also, I found it strange that the package installed subversion as a dependency, but maybe that was intended.
If not, it can be removed as described here: https://github.com/KDE/kdevelop#optional-dependencies

The program links against the subversion package, therefore it is added automatically a dependency.

kdev-python/php are now in for next sync. Please make package requests in future (via side bar on main page) as a comment on a closed task may not be seen.