Page MenuHomeSolus

KDE background colour issues with most recent update on lutris
Closed, ResolvedPublic

Description

Some (seemingly not QT) packages have issues with the default Plasma theme (which I assume was Solus Dark) since I rebooted after yesterday's update. The dark theme in Lutris for example is no longer respected:

The button colours change colour too.
Similarly in Firefox when downloading the button background changes from white to black to blue:



In the second case "Open with..." is selected but hard to see.

I tried to change the theme to Breeze or Breeze Dark but the issues persist. Also when I selected Solus Dark that was not the same theme as originally (which was whatever defaulted with the iso), not sure if it was changed or if it's just been changed due to this.

I am not certain if I rebooted after last weeks update so can't be 100% sure it was from yesterday's. Apologies for vagueness.

Event Timeline

padraig created this task.Oct 26 2019, 9:53 AM

It's probably caused by the same issue as mentioned in T8429 and is reported upstream https://bugs.kde.org/show_bug.cgi?id=412078

Hi Girtablulu, I'm not sure if it's okay to reopen tasks here but although that upstream KDE bug is resolved, has been implemented and is no longer an issue in Firefox, it is still an issue for me with Dark theme on Lutris (not for light theme though), the images above persists. Maybe I should try rebuilding Lutris locally now that the error is fixed and it will be okay if this is only affecting me though.

@padraig upstream says it will be fixed in librsvg 2.46.4 but we are still on 2.46.2, so I guess this needs to be updated before lutris will be fine

Girtablulu reopened this task as Open.Nov 15 2019, 10:19 AM
Girtablulu edited projects, added Software; removed Plasma.
Girtablulu added a subscriber: JoshStrobl.

Totally forgot to reopen it..

@JoshStrobl as the maintainer is it possible to update librsvg to 2.46.4 without hassle?

Girtablulu renamed this task from KDE background colour issues with most recent update to KDE background colour issues with most recent update on lutris.Nov 15 2019, 10:19 AM
Girtablulu closed this task as Resolved.Nov 16 2019, 12:08 PM
Girtablulu claimed this task.

This should be solved, KDE reverted as well the changes which caused them

Unfortunately this is still an issue on Lutris on one of my laptops (not sure why the other is unaffected). Even after the last two updates and rebooting dark theme on Lutris still does is like the screenshot in the first post, this is on a Dell Lattitude 7290 with an i7-8650U.

padraig reopened this task as Open.Jan 28 2020, 6:01 PM

I'm not sure if I'm allowed re-open but this is still an issue for me on two of my Plasma machines. The one it's not an issue on originally was Budgie and then I installed Plasma as well. That's the only one where dark theme in Lutris changes the theme. In the other two pure Plasma machines it is the same as the first screenshot above.

@padraig even if you set the gtk theme to breeze-dark? Because it works as it should (as far as I can see)

Doesn't seem to make a difference, although maybe it will after a reboot

Girtablulu triaged this task as Needs More Info priority.Jan 29 2020, 9:28 PM

@padraig I cannot recreate this on a fresh build iso, I can switch to a dark lutris theme while having a light desktop theme. I did some changes to breeze-gtk in unstable maybe this fixes it.

Can you try create a new user and check if Lutris behaves the same in this case?

After creating a new user it did indeed work so there must be some older config file messing things up for me. Thanks Girtablulu.

padraig closed this task as Resolved.Feb 6 2020, 8:38 AM