Page MenuHomeSolus

Edge-Scrolling activation gets lost
Open, Needs More InfoPublic

Description

Every time I open Settings/Devices/Mouse & Touchpad, the setting "Edge Scrolling" is OFF.
I can activate it and then it works fine until re-opening the settings dialog. Then it falls back to OFF.

Laptop FJSC Esprimo Mobile U9210, Solus 4.0/4.2 64bit with Budgie

Event Timeline

roebotron updated the task description. (Show Details)Oct 15 2019, 5:04 PM
JoshStrobl triaged this task as Needs More Info priority.Nov 9 2019, 5:31 AM
JoshStrobl edited projects, added Hardware; removed Lacks Project.
JoshStrobl added a subscriber: JoshStrobl.

Could you run the following commands so we can try to figure out what touchpad you have? Then I can more easily check if there are any filed kernel or libinput bugs against it:

  1. cat /proc/bus/input/devices | grep 'Touchpad'
  2. dmesg | grep -e "Touchpad" -e "Mouse"

Thanks!

roebotron added a comment.EditedNov 17 2019, 7:49 PM

Hi Josh
Thanks for your response.
Writing this, my laptop is in its docking station, where the setup might look a little bit weird (one Logitech Mouse connected directly, another via a PS2-KVM switch), but I think it shouldn't matter for figuring out that my laptop has a synaptics touchpad:

xxxx@solus ~ $ cat /proc/bus/input/devices | grep 'Touchpad'
xxxx@solus ~ $ dmesg | grep -e "Touchpad" -e "Mouse"
[    4.461498] input: CHESEN PS2 to USB Converter Mouse as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6.4/2-6.4.2/2-6.4.2:1.1/0003:0A81:0205.0002/input/input6
[    4.513738] hid-generic 0003:0A81:0205.0002: input,hidraw1: USB HID v1.10 Mouse [CHESEN PS2 to USB Converter] on usb-0000:00:1d.7-6.4.2/input1
[    6.741834] psmouse serio4: synaptics: Touchpad model: 1, fw: 7.0, id: 0x1c0b1, caps: 0xd04791/0xb02000/0x20000/0x0, board id: 0, fw id: 510125
[   40.181839] usb 2-6.2: Product: USB Laser Mouse
[   40.189710] input: Logitech USB Laser Mouse as /devices/pci0000:00/0000:00:1d.7/usb2/2-6/2-6.2/2-6.2:1.0/0003:046D:C069.0004/input/input26
[   40.189885] hid-generic 0003:046D:C069.0004: input,hidraw3: USB HID v1.10 Mouse [Logitech USB Laser Mouse] on usb-0000:00:1d.7-6.2/input0

Currently, the edge scrolling feature is stable working even after restart, but still falls back to OFF when opening the settings dialog page containing its configuration.

Regards
Frank

This bug ist still open and present: Once I open the settings dialog, the "edge scrolling" switch falls back to OFF. Switching to ON enables the feature instantly and effectively until opening the settings dialog again.
That's annoying...

roebotron raised the priority of this task from Needs More Info to Normal.Feb 7 2021, 12:10 PM
roebotron updated the task description. (Show Details)
JoshStrobl lowered the priority of this task from Normal to Needs More Info.Feb 7 2021, 12:40 PM

Sorry @Josh: "Needs more info" - which info is needed?
Regards
Frank