Page MenuHomeSolus

Add Hyper-V support in kernel + drivers
Closed, WontfixPublic

Description

Is it possible to get Hyper-V (generation 2) support in Solus? As I understand it, the first step is that CONFIG_HYPERV is set in the kernel config.

https://cateee.net/lkddb/web-lkddb/HYPERV.html

Event Timeline

tobcro created this task.Aug 22 2019, 8:51 AM
JoshStrobl triaged this task as Needs More Info priority.Aug 22 2019, 2:00 PM
JoshStrobl edited projects, added Software; removed Lacks Project.
JoshStrobl added a subscriber: JoshStrobl.

What's your usecase for wanting us to enable Hyper-V support? The intended behavior of Solus is to run on physical hardware, not a virtualized environment. Only reason why VirtualBox guest support was added in the first place was to offer at least some easy way for distribution reviewers to review Solus, VirtualBox with Solus has a host has a broader usecase (like using it with Vagrant).

My main usecase is that VirtualBox is slowly but steadily fading away in the Windows ecosystem, as VirtualBox and Hyper-V can not coexist. More and more applications i Windows depend on parts of Hyper-V, not just Hyper-V itself. So for people that would be interested to review or try out Solus in a Windows 10 environment (or as in my personal case, use my work laptop to work with diffrerent virtual machines) it is just not possible, while many other distributions offer this possibility. Right now I am using Ubuntu MATE running Hyper-V and xRDP with very good results.

I understand that this usecase is not the intended one, but since I am a huge fan of Solus I want to be able to use it everywhere. Right now I have to keep a second laptop with Solus as host (and my multiple Solus guests).

I can't say I see the need for it. VirtualBox is not going anywhere, contrary to what you might think. And in order to use Hyper-V you have to have at least a Windows Pro or Enterprise license. The majority of Windows installs on Laptops and Desktops are going to be Windows Home Edition, which doesn't even support Hyper-V. So I would think it exceptionally rare for even a Linux reviewer to have a more advanced license. We also support VMWare Workstation through open-vm-tools which is far more common than Hyper-V amongst reviewers.

I agree that VirtualBox itself is not going anywhere, but VirtualBox (and VMware Workstation) on Windows hosts are in fact leaving the building - at least from Microsofts point of view which eventually often becomes the Windows users point of view. There is the Windows Subsystem for Linux (WSL) steadily growing, a linux kernel in Windows 10 itself and support for nearly all other distributions now as pure virtual machines in Hyper-V. It is still possible (at this date) to get rid of Hyper-V on Windows 10, but it gets harder and harder for each release since the hypervisor in Hyper-V is more and more used in other Microsoft applications and developer tools (like WSL) as well.

But if adding CONFIG_HYPERV in the kernel config would adventure the stability or cause other issues in Solus, I have full respect if you decide to leave it out.

That's patently false. WSL is more a replacement for Cygwin than anything. It's not a VM and doesn't afford the same kind of isolation. It also doesn't rely on Hyper-V as much as you think. It's much closer to WINE than an actual hypervisor solution.

It has nothing to do with stability. I don't want to bloat the kernel with unnecessary drivers and features.

tobcro added a comment.EditedAug 23 2019, 8:22 AM

Good point with WSL, it is true that it actually does not use the hypervisor - yet. I stand corrected.

If you want pure examples of modern Windows applications/services that are relying on the hypervisor right now there is Device Guard and Credential Guard. The latter is the reason for that I can not turn off or remove Hyper-V on my work laptop. And there will be more.

https://blogs.technet.microsoft.com/ash/2016/03/02/windows-10-device-guard-and-credential-guard-demystified/

Sure but none of that has to do with enabling Hyper-V support in our kernel modules. My point was, you are asking us to support a niche-of-a-niche use-case and I'm not sure that we want to support yet another hypervisor.

tobcro added a comment.EditedAug 23 2019, 9:30 AM

Well.. lets agree to disagree :) Honestly, I understand your doubts, but I very much believe that the demand for CONFIG_HYPERV in Solus will be rising in the future. Thank you for your time and consideration.

JoshStrobl closed this task as Wontfix.Aug 23 2019, 2:22 PM

I very much believe that the demand for CONFIG_HYPERV in Solus will be rising in the future

Well when that demand is obvious to Core Team, we'll see if it's reasonable to enable it. But as mentioned by Bryan, it's extremely niche at this moment in time (sorry but there is no amount of people of consequence that really reviews Linux distributions on Windows) and would bloat the kernel.