Page MenuHomeSolus

New package: WireGuard
Closed, DuplicatePublic

Description

  • Name of the software

wireguard

  • Project/product Homepage

https://www.wireguard.com/

  • Why we should include this into the repository, i.e. what does it do that the alternatives do not?

I quote from the page above:

WireGuard® is an extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography. It aims to be faster, simpler, leaner, and more useful than IPsec, while avoiding the massive headache.

I find this to be incredibly true and often run into hiccups or simply annoying additions to VPN software which ruin my experience. I want to have a simple way of enabling and disabling my VPN. WireGuard has done this for me in the past and I hope it does in the future.

  • Is it open source?

It aims to be: https://git.zx2c4.com/WireGuard/

  • Please provide a link to the most up to date versioned source tarball/zipfile:

https://www.wireguard.com/install/
For which distro? :^)

  • Please provide a link to the source repository (i.e. GitHub)

https://git.zx2c4.com/WireGuard/

Related Objects

Mentioned Here
T3778: WireGuard

Event Timeline

Farcrada created this task.Jul 18 2019, 8:13 PM
Jacalz added a subscriber: Jacalz.Jul 18 2019, 8:17 PM

Duplicate of T3778

Farcrada closed this task as a duplicate of T6438: WireGuard.Jul 18 2019, 8:21 PM

Yeah I noticed that a tad too late @Jacalz. My bad.

Merged them as duplicate, though!

Yeah I noticed that a tad too late @Jacalz. My bad.
Merged them as duplicate, though!

Thanks! We all make mistakes, no worries 🙂