Page MenuHomeSolus

Screen tearing in xorg-server 1.20.5
Closed, ResolvedPublic

Description

After this week's sync I have been experiencing graphical issues in the form of screen tearing in vsync-enabled video games and also in the Budgie UI when opening/closing Raven. Rolling back to last week's sync (June 7th I think) resolves the issue, so it is the June 14th sync that causes it.

Edit: The issue is present in KDE Plasma as well.

Edit 2: The bug is caused by xorg-server 1.20.5, probably because xorg-driver-video-intel hasn't been updated upstream to support the latest changes in server (related Arch Linux bug report). Downgrading to the previous xorg-server build (1.20.3) resolves the issue. Perhaps a rollback is in order until fixed upstream?

Edit 3: Removing xorg-driver-video-intel and defaulting to modesetting fixes the issue (or lessens it such that the tearing is invisible), supporting the idea that this has to do with the Intel driver.

Event Timeline

abdulocracy edited projects, added Software; removed Lacks Project.Jun 17 2019, 8:16 PM
This comment was removed by abdulocracy.
This comment was removed by abdulocracy.
This comment was removed by abdulocracy.
This comment was removed by abdulocracy.
abdulocracy renamed this task from Screen tearing after latest sync to Screen tearing in xorg-server 1.20.5.Jul 4 2019, 7:45 PM
abdulocracy updated the task description. (Show Details)
abdulocracy updated the task description. (Show Details)Jul 4 2019, 7:52 PM
abdulocracy updated the task description. (Show Details)
Jacek awarded a token.Jul 18 2019, 4:15 PM
Jacek added a subscriber: Jacek.
DataDrake triaged this task as Needs More Info priority.Jul 25 2019, 11:51 AM
DataDrake added a subscriber: DataDrake.

I'm not rolling back xorg-server, but I do know that some Intel devices work better without the xorg video driver (my work desktop included). If removing it is a working fix for you, I would encourage you to share the make/model of your machine for others and mark this as resolved for the moment.

The machine which needed removal of xorg-driver-video-intel in order to work properly was a ThinkPad X220. I am currently on an XPS 13 9360 and the issue is not present, the Intel driver works fine.

Jacek added a comment.EditedJul 25 2019, 12:19 PM

Both my 7 years old XPS with i5-3317U and my netbook with Intel Atom Kaby Lake CPU have that issue, so this would seem that this problem only affects devices with i915 driver and not newer ones supported by "Iris" Gallium driver. But I might be totally wrong.

DataDrake closed this task as Resolved.Sep 26 2019, 2:46 AM
DataDrake claimed this task.

Marking as resolved since we have a known workaround now.