Page MenuHomeSolus

Broken dependency for Thonny IDE
Closed, ResolvedPublic

Description

Some users report that they can't run Thonny. It's seem like one of the dependency, python-typed-ast, is not up to date.

The user's report: https://discuss.getsol.us/d/1321-thonny-python-ide-install-problems/2

Link to new python-typed-ast's tarball: https://files.pythonhosted.org/packages/34/de/d0cfe2ea7ddfd8b2b8374ed2e04eeb08b6ee6e1e84081d151341bba596e5/typed_ast-1.4.0.tar.gz

Related Objects

Event Timeline

yursan9 created this task.Jun 16 2019, 11:07 PM
Staudey added a subscriber: Staudey.EditedJun 17 2019, 5:23 PM

It actually seems it's TOO up-to-date ^^

pkg_resources.ContextualVersionConflict: (typed-ast 1.3.5 (/usr/lib64/python3.6/site-packages), Requirement.parse('typed-ast<1.2.0,>=1.1.0'), {'mypy'})

Unfortunately the newer typed_ast version seems to be a requirement of the newer python-astroid (D6404)

Oh, the requirement actually comes from python-mypy which hasn't been updated in ages and works fine in the newer version. Gonna update it in a bit.

Done.
Note that we shouldn't update python-typed-ast to 1.4.0 because even the newest mypy version only works with "<1.4.0"