Page MenuHomeSolus

Broken dependency for Thonny IDE
Closed, ResolvedPublic


Some users report that they can't run Thonny. It's seem like one of the dependency, python-typed-ast, is not up to date.

The user's report:

Link to new python-typed-ast's tarball:

Related Objects

Event Timeline

yursan9 created this task.Jun 16 2019, 11:07 PM
Staudey added a subscriber: Staudey.EditedJun 17 2019, 5:23 PM

It actually seems it's TOO up-to-date ^^

pkg_resources.ContextualVersionConflict: (typed-ast 1.3.5 (/usr/lib64/python3.6/site-packages), Requirement.parse('typed-ast<1.2.0,>=1.1.0'), {'mypy'})

Unfortunately the newer typed_ast version seems to be a requirement of the newer python-astroid (D6404)

Oh, the requirement actually comes from python-mypy which hasn't been updated in ages and works fine in the newer version. Gonna update it in a bit.

Note that we shouldn't update python-typed-ast to 1.4.0 because even the newest mypy version only works with "<1.4.0"