Page MenuHomeSolus

software center sometime freezing on large packages (and eventually quits)
Closed, LockedPublic

Description

have been having software centre occasionally stop/fail to install stuff, for maybe 6-months+

it 'sticks' installing for hours, then i find it has closed, when i restart there's still the same packages reported as needing updating.

i found a work-round; installing packages in small groups.

i am reporting now as i have just noticed that software centre always 'sticks' showing 'golang' being installed.

separately installing everything EXCEPT 'golang' works, then 'golang' by itself, works.

seems that it could have always been updates to 'golang' when this happened.

Event Timeline

si created this task.May 25 2019, 9:19 PM
DataDrake edited projects, added Software; removed Lacks Project.Jun 8 2019, 7:41 PM
si closed this task as Resolved.Jun 14 2019, 11:53 PM
si claimed this task.

Todays golang ++ big update went without hitch either fixed or never was!

si reopened this task as Open.Oct 6 2019, 4:51 PM

noticed again same thing, seems to be large packages, confirmed on another machine with clean install.

some resource limit reached? (mem ram...)

si renamed this task from golang installation freezing when updated with other packages to software center sometime freezing on large packages (and eventually quits).Oct 6 2019, 4:53 PM

I think it has something to do with eopkg, I usually update/install packages using the command line and from time to time on large downloads eopkg just freezes, probably due to its implementation.

This bug will probably be fixed with Sol, eopkg's successor as Solus' package manager

si added a comment.Nov 7 2019, 6:11 PM

looks like Sol is no longer in dev.

In T7989#160563, @si wrote:

looks like Sol is no longer in dev.

It absolutely is. Just delayed. Please don't spread misinformation.

si added a comment.Nov 8 2019, 10:56 PM

i'm not, it LOOKS like it is no longer in dev. (see github page)

I think most of Sol's development is done here on phabricator, in a hidden repo.

The Solus team doesn't have full access to the "solus-project" GitHub organization so everything by this organization is either forked somewhere else of depreciated

In T7989#160607, @si wrote:

i'm not, it LOOKS like it is no longer in dev. (see github page)

You are talking to the person who is actually writing it. It's still in development, just not in that repo. That was a one-off when Ikey started working on his version of it. My design is very different, written in Go instead of C, and not yet in a state I am comfortable sharing.

I think most of Sol's development is done here on phabricator, in a hidden repo.

I do most of my early development locally because I don't want to be flooded with issues and PRs during the design process. Once I am caught up on other higher priority projects (i.e. ferryd) and the code is in a state that I am comfortable sharing, it will be in a new repo under the Solus Github organization.

si added a comment.Nov 9 2019, 12:14 AM

OK. Good. but if you don't want it to look like its no longer in dev. you might think about putting the last post on the github page.

and

responding to the query, from a year ago, asking if the project was dead?

https://github.com/solus-project/sol/issues/7

We've already covered this in numerous places including our blog. I see no reason to go back and necro a repo on a github org we aren't using anymore.

si added a comment.Nov 9 2019, 12:29 AM

googling gets you there.

why not mark it as defunct? would have saved us both having this conversation.

Because I feel no need to. It doesn't come up that often and right now you are the only one making a big deal out of it.

JoshStrobl closed this task as Locked.Nov 9 2019, 5:09 AM
JoshStrobl changed the edit policy from "Custom Policy" to "Restricted Project (Project)".
si added a comment.Nov 9 2019, 5:50 PM
This comment was removed by JoshStrobl.
JoshStrobl removed si as the assignee of this task.Nov 9 2019, 7:05 PM
This task has been locked.