Page MenuHomeSolus

W18 update breaks kodi
Closed, InvalidPublic

Description

starting kodi with X11 renders no UI, just splash-screen

  • tried with empty dotkodi with same result
  • tried with dotkodi non-empty with same result
  • tried with i3, budgie and --standalone (as GDM wm) with same result

logfile contains some warnings and an error about upnp::getresource failing to locate folder.jpg but this does not particularly points to root cause; neither upstream issue-tracker specifies an issue that might have been a root cause; building locally makes kodi working again, therefore it must be configuration issue; I used build command from package.yml; note, however, in order to build locally I had to edit two cpp files of 18.2 release where macro HAS_MARIADB is defined it points to /usr/include/mariadb but right one is /usr/include/mysql.

Edit: as @Harvey pointed out I was not up-to-date

Event Timeline

nazar created this task.May 5 2019, 7:01 AM
Herald removed ermo as the assignee of this task. · View Herald TranscriptMay 5 2019, 7:01 AM
Herald added a subscriber: ermo.
Harvey added a subscriber: Harvey.May 5 2019, 7:18 AM

Are you sure you're up to date? Because ermo pushed an update to fix this.

sudo eopkg up
nazar closed this task as Invalid.May 5 2019, 7:21 AM
nazar updated the task description. (Show Details)