Page MenuHomeSolus

GIMP Segfaulted
Closed, ResolvedPublic

Description

GIMP sent me here. It crashed when I was picking a filter and opened a dialogue box that offered redirecting me to the "bug tracker" aka this site

So I'm following through. Here are the error details:

GNU Image Manipulation Program version 2.10.8
git-describe: GIMP_2_10_6-294-ga967e8d2c2
C compiler:
	Using built-in specs.
	COLLECT_GCC=x86_64-solus-linux-gcc
	COLLECT_LTO_WRAPPER=/usr/lib64/gcc/x86_64-solus-linux/8/lto-wrapper
	Target: x86_64-solus-linux
	Configured with: ../configure --prefix=/usr --with-pkgversion=Solus --libdir=/usr/lib64 --libexecdir=/usr/lib64 --with-system-zlib --enable-shared --enable-threads=posix --enable-gnu-indirect-function --enable-__cxa_atexit --enable-plugin --enable-gold --enable-ld=default --enable-clocale=gnu --enable-multilib --with-multilib-list=m32,m64 --enable-lto --with-gcc-major-version-only --with-bugurl=https://dev.solus-project.com/ --with-arch_32=i686 --enable-linker-build-id --with-linker-hash-style=gnu --with-gnu-ld --build=x86_64-solus-linux --target=x86_64-solus-linux --enable-languages=c,c++,fortran
	Thread model: posix
	gcc version 8.3.1 20190320 (Solus) 
	
using GEGL version 0.4.12 (compiled against version 0.4.12)
using GLib version 2.56.3 (compiled against version 2.56.3)
using GdkPixbuf version 2.38.0 (compiled against version 2.38.0)
using GTK+ version 2.24.31 (compiled against version 2.24.31)
using Pango version 1.42.4 (compiled against version 1.42.4)
using Fontconfig version 2.13.0 (compiled against version 2.13.0)
using Cairo version 1.16.0 (compiled against version 1.16.0)

fatal error: Segmentation fault

Stack trace:

# Stack traces obtained from PID 1800 - Thread 6042 #

[New LWP 1801]
[New LWP 1802]
[New LWP 1803]
[New LWP 1804]
[New LWP 1805]
[New LWP 1806]
[New LWP 1959]
[New LWP 2099]
[New LWP 6041]
[New LWP 6042]
To enable execution of this file add
	add-auto-load-safe-path /usr/lib64/libthread_db-1.0.so
line to your configuration file "/home/hazem/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/hazem/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
0x00007fc5981c4856 in ?? () from /usr/lib/libgegl-0.4.so.0
  Id   Target Id              Frame 
* 1    LWP 1800 "gimp-2.10"   0x00007fc5981c4856 in ?? () from /usr/lib/libgegl-0.4.so.0
  2    LWP 1801 "gmain"       0x00007fc597a647e9 in poll () from /usr/lib/libc.so.6
  3    LWP 1802 "gdbus"       0x00007fc597a647e9 in poll () from /usr/lib/libc.so.6
  4    LWP 1803 "async"       0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  5    LWP 1804 "worker"      0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  6    LWP 1805 "worker"      0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  7    LWP 1806 "worker"      0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  8    LWP 1959 "swap writer" 0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  9    LWP 2099 "paint"       0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  10   LWP 6041 "pool"        0x00007fc597a6a2b9 in syscall () from /usr/lib/libc.so.6
  11   LWP 6042 "pool"        0x00007fc597b54c44 in read () from /usr/lib/libpthread.so.0

Thread 11 (LWP 6042):
#0  0x00007fc597b54c44 in read () at /usr/lib/libpthread.so.0
#1  0x00007fc59862586c in gimp_stack_trace_print () at /usr/lib/libgimpbase-2.0.so.0
#2  0x00000000004973c0 in  ()
#3  0x00000000004977f8 in  ()
#4  0x0000000000497f77 in  ()
#5  0x00007fc597b55df0 in <signal handler called> () at /usr/lib/libpthread.so.0
#6  0x00007fc5979eb8a2 in malloc () at /usr/lib/libc.so.6
#7  0x00007fc597ee8368 in babl_malloc () at /usr/lib/libbabl-0.1.so.0
#8  0x00007fc597ee6539 in  () at /usr/lib/libbabl-0.1.so.0
#9  0x00007fc597ee6959 in  () at /usr/lib/libbabl-0.1.so.0
#10 0x00007fc597ee0175 in  () at /usr/lib/libbabl-0.1.so.0
#11 0x00007fc597ede666 in babl_process () at /usr/lib/libbabl-0.1.so.0
#12 0x00007fc5981a0f6b in  () at /usr/lib/libgegl-0.4.so.0
#13 0x00007fc5981a1e44 in  () at /usr/lib/libgegl-0.4.so.0
#14 0x00007fc5981a2be2 in  () at /usr/lib/libgegl-0.4.so.0
#15 0x00007fc587c9f8d8 in  () at /usr/lib64/gegl-0.4/gegl-common.so
#16 0x00007fc5981c44cd in  () at /usr/lib/libgegl-0.4.so.0
#17 0x00007fc597d2dfe3 in  () at /usr/lib/libglib-2.0.so.0
#18 0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#19 0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#20 0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 10 (LWP 6041):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4c0ca in g_cond_wait_until () at /usr/lib/libglib-2.0.so.0
#2  0x00007fc597cd7be1 in  () at /usr/lib/libglib-2.0.so.0
#3  0x00007fc597cd819c in g_async_queue_timeout_pop () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597d2e081 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#6  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#7  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 9 (LWP 2099):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x0000000000529c3d in  ()
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 8 (LWP 1959):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x00007fc5981bc05d in  () at /usr/lib/libgegl-0.4.so.0
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 7 (LWP 1806):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x000000000075ca73 in  ()
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 6 (LWP 1805):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x000000000075ca73 in  ()
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 5 (LWP 1804):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x000000000075ca73 in  ()
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 4 (LWP 1803):
#0  0x00007fc597a6a2b9 in syscall () at /usr/lib/libc.so.6
#1  0x00007fc597d4bfaf in g_cond_wait () at /usr/lib/libglib-2.0.so.0
#2  0x000000000075ccbc in  ()
#3  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#5  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 3 (LWP 1802):
#0  0x00007fc597a647e9 in poll () at /usr/lib/libc.so.6
#1  0x00007fc597d059f6 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fc597d05d82 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3  0x00007fc598088e26 in  () at /usr/lib/libgio-2.0.so.0
#4  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#6  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 2 (LWP 1801):
#0  0x00007fc597a647e9 in poll () at /usr/lib/libc.so.6
#1  0x00007fc597d059f6 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007fc597d05b1c in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007fc597d05b61 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007fc597d2d645 in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007fc597b4b16f in  () at /usr/lib/libpthread.so.0
#6  0x00007fc597a70aff in clone () at /usr/lib/libc.so.6

Thread 1 (LWP 1800):
#0  0x00007fc5981c4856 in  () at /usr/lib/libgegl-0.4.so.0
#1  0x00007fc5981d3b79 in gegl_graph_process () at /usr/lib/libgegl-0.4.so.0
#2  0x00007fc5981d3105 in gegl_eval_manager_apply () at /usr/lib/libgegl-0.4.so.0
#3  0x00007fc5981cbba8 in  () at /usr/lib/libgegl-0.4.so.0
#4  0x00007fc5981cc18d in gegl_node_blit () at /usr/lib/libgegl-0.4.so.0
#5  0x00007fc5981d531c in gegl_processor_work () at /usr/lib/libgegl-0.4.so.0
#6  0x00007fc5981cbc6a in gegl_node_process () at /usr/lib/libgegl-0.4.so.0
#7  0x00007fc587befec7 in  () at /usr/lib64/gegl-0.4/gegl-common-gpl3.so
#8  0x00007fc5981c45e4 in  () at /usr/lib/libgegl-0.4.so.0
#9  0x00007fc5981d3b79 in gegl_graph_process () at /usr/lib/libgegl-0.4.so.0
#10 0x00007fc5981d3105 in gegl_eval_manager_apply () at /usr/lib/libgegl-0.4.so.0
#11 0x00007fc5981cba6a in gegl_node_blit_buffer () at /usr/lib/libgegl-0.4.so.0
#12 0x000000000080b060 in  ()
#13 0x000000000080b0ff in  ()
#14 0x000000000080b488 in  ()
#15 0x00007fc597d05698 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#16 0x00007fc597d05a88 in  () at /usr/lib/libglib-2.0.so.0
#17 0x00007fc597d05d82 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#18 0x0000000000496bd7 in app_run ()
#19 0x00000000004964e6 in main ()
[Inferior 1 (process 1800) detached]

Event Timeline

hyphens created this task.Apr 14 2019, 2:37 AM
Girtablulu edited projects, added Software; removed Lacks Project.Apr 14 2019, 1:07 PM
Girtablulu added a subscriber: Girtablulu.

Usual question, are you up to date? (be aware repos are slow today on sunday) and which filter exactly are you trying to use?

The error log says I'm on GIMP 2.10.8
I believe that's the latest.

The filter I was trying to use was one from the artistic category. I can't recall which. Should've noted that. Sorry! I'll try to reproduce and get back to you if the same bug happened again.

can't reproduce..

Girtablulu closed this task as Resolved.Apr 25 2019, 1:03 PM
Girtablulu claimed this task.

I'm going to mark it as resolved then, should it happen again feel free to open a new task with the steps how to reproduce this.