Page MenuHomeSolus

Mouse don't work in neovim on terminal
Closed, WontfixPublic

Description

Testes on mate-terminal, gnome-terminal, tilix, terminator and roxterminal.

Only kitty works.

To reproduce:
Install neovim, open it (nvim) and run :set mouse=a

Tested in Mint, Ubuntu, Arch with sames terminals and init.vim and works.

Like I said in forum, it's probably the vte library fault.

Girtablulu edited projects, added Software; removed Lacks Project.Apr 10 2019, 8:44 AM

Using nvim in tmux works fine though

JoshStrobl triaged this task as Needs More Info priority.Apr 30 2019, 2:11 PM
JoshStrobl added a subscriber: JoshStrobl.

Can you explain explicitly what the mouse support is expected to provide in terms of functionality?

I believe it's a known issue, scrolling in nvim triggers an E73 tag stack empty error, seems to be due to an improper value of $TERM

There are tons of bug reports, this is one of them: https://github.com/jwilm/alacritty/issues/1228

this doesn't happen with st or kitty though

JoshStrobl closed this task as Wontfix.Apr 30 2019, 3:15 PM

Seems more like an issue with those respective projects and not explicitly Solus then. You can always change your TERM.

JoshStrobl edited projects, added Upstream Issue; removed Software.Apr 30 2019, 3:15 PM