Page MenuHomeSolus

Synapse not showing all apps
Closed, WontfixPublic

Description

I noticed that the newly added package "Synapse" does not always find all apps when used by a new user.

Create a new priviledged user, start synapse and try to search for the app "Budgie Settings". The app "Budgie Settings" will not be found!

I packaged the software and can say it is working as intended, the issue is that the file /usr/share/applications/budgie-desktop-settings.desktop includes a line OnlyShowIn=Budgie; by default. @JoshStrobl why do we have this parameter in the desktop file? It seems all Budgie desktop files have had this line since forever, according to the git history.

boustanihani added a comment.EditedApr 4 2019, 11:52 AM

The "Budgie Settings" app shows if the user searching for that app is the first user created during the install process.

Create a new priviledged user, start synapse and try to search for the app "Budgie Settings".
The app "Budgie Settings" will not be found!

Check my screenshot above...

I've tried it on my initial privileged user, and I still cannot see it. The problem vanishes if the flag I mentioned is removed.

boustanihani added a comment.EditedApr 5 2019, 3:25 PM

Yes, deleting OnlyShowIn=Budgie; solves the problem.

JoshStrobl closed this task as Wontfix.Apr 30 2019, 1:57 PM

I don't consider this to be a valid issue. Synapse should be smart enough to know what desktop environment you're running it under, and to show the appropriate desktop entries. I'm not removing the OnlyShowIn from Budgie Desktop Settings, because it is only for Budgie and explicitly requires the budgie-panel.