Page MenuHomeSolus

Google Chrome Flash Player not working
Closed, ResolvedPublic

Description

Installed Google Chrome from the 3rd party repository, when i try to run flash Chrome asks me if i want to allow it to run, i allow it, then after i have a white page saying that i should right click and run the plugin, which i do, but nothing happens after i do it ... tried on multiple websites

I'll take a look at it

Hmm, right, I can't get it to work either. Selecting "Run this plugin" does nothing, and I've tried pretty much everything. Weird.

Doesn't work with the dev channel version either. I wanted to try the Chromium snap too for good measure but ran into a snap-related problem ^^

kronikpillow added a comment.EditedMar 21 2019, 11:33 PM

I tried installing the flash plugins but no effect, on Chrome flash should work out of the box as it's integrated in to it ... and it works perfectly fine on my other Linux distros

siru added a subscriber: siru.Mar 22 2019, 11:23 AM

Hmm, it works when run as root with disabled sandbox (NOT RECOMMENDED). No idea what the underlying issue is though.

kronikpillow added a comment.EditedMar 24 2019, 8:12 AM

did i report this bug to the appropriate place (I have found a couple of more bugs related to other apps but not sure if I'm supposed to report them here)? disabling sandbox kinda beats the purpose of chrome

kronikpillow added a comment.EditedMar 24 2019, 6:39 PM

@Staudey I think I have figured it out after i switched to Solus MATE, i watched the Install Output of Google Chrome, and I receive a warning during install of chrome ... tried googling the output and some hits mention inproper permissions for chrome-sandbox .... I haven't got the skills yet to figure it out on my own

here is the output log:
https://hastebin.com/kapefoziwa.coffeescript

very easily might be something related to permissions, as it works under root, which means that root has permissions to read/write to it while the user doesn't ....

I also noticed that my user by default, isn't part of the "wheel" group ... i get that when i try to output journalctl -b > log.txt as a user so i need to sudo it to see messages from all users

output:
https://hastebin.com/alakiwozuy.coffeescript

this might be creating permission issues for apps, as on other distros a admin user is part of these groups

Journalctl shows the following after selecting "Run this plugin"

Mär 28 18:12:52 solus-pc audit[9069]: ANOM_ABEND auid=4294967295 uid=1000 gid=1000 ses=4294967295 subj==unconfined pid=9069 comm="chrome" exe="/opt/google/chrome/chrome" sig=31 res=1
kronikpillow added a comment.EditedMar 28 2019, 7:40 PM

I have just tested it on Antergos (Arch based) and on MXLinux (Debian based) and it works perfectly fine

kronikpillow added a comment.EditedMar 28 2019, 8:41 PM

also, when i installed Solus GNOME, Chrome says that my chrome is managed by my Organization ... o.O I am not part of any organization
this is where it shows that I'm managed by my organization


and this is where it shows that I am not part of a organizatio

this is only visible on Solus GNOME, but maybe this could be the issue?
just bad packaging?

Hello to all,

Kyrios sent me there, as the same problem occurs when using Opera or Vivaldi in Solus Budgie. With Manjaro Budgie, be it with Opera or Vivaldi, Flash works out of the box. Hope this may be helpful.

Oh interesting. Vivaldi from the repository doesn't work?
Thank you for the additional data point! Not sure where to go from here to be honest. I did quite a bit of googling and tinkering around but I'm way out of my depth in this case.

Be it Vivadi-stable or snapshot, yes, from the repository. Flash won't work. neither with Opera.

so it's a Chromium browser related issue with Solus, as all these browsers work perfectly fine on my other distros .... also on Solus 3.99999 this problem didn't exist as i used pepper flash on it

DataDrake triaged this task as Normal priority.Apr 30 2019, 2:11 PM

Hello! New think: after last update on Manjaro Budgie, Flash on Opera doesn't work anymore. Same problem.

kronikpillow added a comment.EditedMay 1 2019, 8:02 PM

that doesn't have anything to do with Google Chrome mate, Opera is Chromium based, Google Chrome is Google Chrome, flash works, on every single one of the browsers that I'm using ever since i switched from Solus, I had to switch because Flash is cruicial to my workflow as some apps I use are in flash ... try installing pepperflash on Manjaro and you will see it works

Hello! New think: after last update on Manjaro Budgie, Flash on Opera doesn't work anymore. Same problem.

Interesting. I hope they fix this and I can learn something from their fix 😆

kronikpillow added a comment.EditedMay 17 2019, 2:47 PM

I have come across this article, could this be the problem? I'm not quite sure how to make this simlink on solus, tried the described command but doesn't work
https://pw999.wordpress.com/2017/06/16/flash-wont-work-in-google-chrome-for-linux/

Whoops, forgot to comment:

I've tried that method but it didn't seem to make any difference.

firefox with Flash Player(NPAPI) works fine though

Flash in Chrome works fine again now. Thanks to Justin for the heads-up! This can be closed.

Justin closed this task as Resolved.Jun 6 2019, 10:24 AM
Justin claimed this task.
Justin added a subscriber: Justin.

As per my commit on 3rd party, this is now fixed in latest Chrome stable.