Page MenuHomeSolus

Joplin the Note-taking Program
Closed, DuplicatePublic

Description

Hello,

I'd like to suggest for Solus repository the note-taking program Joplin. My expertise is not enough to compile it myself, so this is merely a proposal.

Homepage: https://joplin.cozic.net/

Why should this be included in the repository? It is one of the most promising cross-platform notepad applications available.

Is it open-source? Yes

Who and how many users do you anticipate will use this software? Anyone who uses the computer to jot things down and organize these notes.

Link to source tarball/zip file https://github.com/laurent22/joplin/archive/v1.0.127.tar.gz

Event Timeline

JoshStrobl closed this task as a duplicate of T6488: Joplin Integration.Mar 7 2019, 4:53 AM
iptent added a subscriber: iptent.May 9 2019, 8:05 PM

The combination of joplin and syncthing is a "just works" way to sync notes & attachments between Android and computer without using the cloud or creating one's own server. Zim and Boostnote don't have Android apps, but joplin does. I was able to install joplin on solus 3.9999, but I'm running into difficulties with 4.0. It would be nice if there was an easy way to get this on to solus. (I'm no expert--just trying out Win10 alternatives to be ready for Win 7 goes away.) Thanks.

bentry added a comment.Oct 4 2019, 2:17 PM

All Joplin requests got closed, does that mean it's rejected for good? It was said that value add was required, so I wrote some of that up, but the task got closed without comment. If this is to mean a plain rejection of Joplin, please just say so outright.

If you read the other Joplin task, it should be clear we do not plan on accepting it into the repository. You are welcome to use a flatpak or snap of it, should Joplin provide it.

iptent added a comment.Oct 4 2019, 3:31 PM

I've gotten the app image to work.

bentry added a comment.Oct 4 2019, 5:58 PM

If you read the other Joplin task, it should be clear we do not plan on accepting it into the repository. You are welcome to use a flatpak or snap of it, should Joplin provide it.

Thank you for your response. I did read the other Joplin task, which is exactly why I created my own Joplin task today. You said in the comments that there was no value added as compared to already accepted software, which is not true to the facts. All this is easy to miss, hence I wrote down the reasoning in a more concise way than in the other tasks. You can not do with file system sync what you can do with Joplin: Crossplatform sync (that includes iOS and Android clients) which is end-to-end encrypted and includes support for mathematical equations, all at the same time. I have tried to look into what is available already and found that I can absolutely not have these features in any other application at once. I would lose math support (which is a dealbreaker to many a note-taker) and mobile support, even if I shoehorn other apps into cryptomator encryption or something like that. Joplin is the only app that does it all AFAIK, but please feel free to correct me if I'm wrong there, it would save me hassle as well :)

Thank you for your feedback, it's been rejected per our package inclusion policy and my decision is final on the matter.