Page MenuHomeSolus

Problem install snaps
Closed, ResolvedPublic

Description

Hi,

i cant run snaps.

Error:

snapd-2.37.2-35-1-x86_64.eopkg [cached]
Installing snapd, version 2.37.2, release 35
Extracting the files of snapd
Installed snapd
[✓] Syncing filesystems success
[✓] Updating systemd tmpfiles success
[✓] Reloading systemd configuration success

**⌛ Compiling AppArmor profiles                                        runningChild process '/usr/sbin/aa-lsm-hook-compile' exited abnormally**

[✓] Compiling AppArmor profiles success

**⌛ Reloading AppArmor profiles                                        runningChild process '/usr/sbin/aa-lsm-hook-load' exited abnormally**

[✓] Reloading AppArmor profiles success
[✓] Updating manpages database success
[✓] Reloading udev rules success
[✓] Applying udev rules success

sudo systemctl status snapd
● snapd.service - Snappy daemon

Loaded: loaded (/usr/lib/systemd/system/snapd.service; disabled; vendor preset: enabled)
Active: active (running) since Sat 2019-02-16 13:29:33 WET; 23min ago

Main PID: 1246 (snapd)

 Tasks: 18 (limit: 4915)
Memory: 223.3M
CGroup: /system.slice/snapd.service
        └─1246 /usr/lib64/snapd/snapd

fev 16 13:29:33 gollum systemd[1]: Starting Snappy daemon...
fev 16 13:29:33 gollum snapd[1246]: AppArmor status: apparmor is enabled and all features are available
fev 16 13:29:33 gollum snapd[1246]: daemon.go:379: started snapd/2.37.2 (series 16; classic) solus/3.9999 (amd64) linux/4.20.8-110.current.
fev 16 13:29:33 gollum systemd[1]: Started Snappy daemon.
fev 16 13:30:34 gollum snapd[1246]: api.go:1077: Installing snap "spotify" revision unset
fev 16 13:42:43 gollum snapd[1246]: udevmon.go:139: udev event error: Unable to parse uevent, err: cannot parse libudev event: invalid env data
fev 16 13:51:18 gollum snapd[1246]: udevmon.go:139: udev event error: Unable to parse uevent, err: cannot parse libudev event: invalid env data
fev 16 13:51:49 gollum snapd[1246]: udevmon.go:139: udev event error: Unable to parse uevent, err: cannot parse libudev event: invalid env data
fev 16 13:52:03 gollum snapd[1246]: udevmon.go:139: udev event error: Unable to parse uevent, err: cannot parse libudev event: invalid env data
 nuno  ~  systemctl status snapd.apparmor.service
● snapd.apparmor.service - Load AppArmor profiles managed internally by snapd

Loaded: loaded (/usr/lib/systemd/system/snapd.apparmor.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Girtablulu triaged this task as Unbreak Now! priority.Feb 16 2019, 1:57 PM
Girtablulu assigned this task to DataDrake.
Girtablulu added a subscriber: Girtablulu.

yep Core is aware and already looking into it

Hi @Girtablulu , thks

And AppArmor error?

Regards

Lorien added a subscriber: Lorien.Feb 16 2019, 2:13 PM
Okra added a subscriber: Okra.Feb 16 2019, 11:06 PM

Can someone on Unstable confirm that the new aa-lsm-hook package resolves this?

Is fixed for me but had to reboot for it

Fixed for me to with the new aa-lsm-hook package, thanks.

Girtablulu closed this task as Resolved.EditedFeb 17 2019, 5:27 PM

Resolved by c5b2b138e8f1, cherry picked to shannon