Page MenuHomeSolus

Lutris won't start
Closed, ResolvedPublic

Description

Updated to lutris-0.5.0-31, it won't start. Log:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 31, in <module>
    from lutris.gui.application import Application
  File "/usr/lib/python3.6/site-packages/lutris/gui/application.py", line 34, in <module>
    from lutris.game import Game
  File "/usr/lib/python3.6/site-packages/lutris/game.py", line 14, in <module>
    from lutris.runners import import_runner, InvalidRunner, wine
  File "/usr/lib/python3.6/site-packages/lutris/runners/wine.py", line 10, in <module>
    from lutris.gui.dialogs import FileDialog
  File "/usr/lib/python3.6/site-packages/lutris/gui/dialogs/__init__.py", line 12, in <module>
    gi.require_version("WebKit2", "4.0")
  File "/usr/lib/python3.6/site-packages/gi/__init__.py", line 130, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace WebKit2 not available

It was running fine on previous version, 0.4.23-26.
Im on a fully updated Solus Plasma. If you ever need more logs, just give me whistle.

Event Timeline

EQLucky created this task.Feb 3 2019, 4:44 AM

Hmm, I cannot reproduce it. Can you check if you have installed python-gobject? But you should if you're able to use the Software Center.

Hmm, I cannot reproduce it. Can you check if you have installed python-gobject? But you should if you're able to use the Software Center.

Already have it installed, as you supposed:

 eqlucky  ~  sudo eopkg it python-gobject
Password: 
The following package(s) are already installed and are not going to be installed again:
python-gobject
No packages to install.
 eqlucky  ~  lutris
Traceback (most recent call last):
  File "/usr/bin/lutris", line 31, in <module>
    from lutris.gui.application import Application
  File "/usr/lib/python3.6/site-packages/lutris/gui/application.py", line 34, in <module>
    from lutris.game import Game
  File "/usr/lib/python3.6/site-packages/lutris/game.py", line 14, in <module>
    from lutris.runners import import_runner, InvalidRunner, wine
  File "/usr/lib/python3.6/site-packages/lutris/runners/wine.py", line 10, in <module>
    from lutris.gui.dialogs import FileDialog
  File "/usr/lib/python3.6/site-packages/lutris/gui/dialogs/__init__.py", line 12, in <module>
    gi.require_version("WebKit2", "4.0")
  File "/usr/lib/python3.6/site-packages/gi/__init__.py", line 130, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace WebKit2 not available
EQLucky closed this task as Resolved.Feb 3 2019, 6:05 PM
EQLucky claimed this task.

Ok, it wasn't python-gobject, but libwebkit-gtk. It should be included as dependency, just becuase as soon as I installed it, it worked flawlessly with my previous configuration.

Cheers.

I confim that I have libwebkit-gtk installed because of emacs. I'll add it to the rundeps if no one will overtake me.

JoshStrobl reopened this task as Open.Feb 3 2019, 6:43 PM
JoshStrobl triaged this task as Normal priority.
JoshStrobl edited projects, added Software; removed Lacks Project.
JoshStrobl added a subscriber: JoshStrobl.

Not sure why you would mark this as resolved given the rundep wasn't yet added.

I confim that I have libwebkit-gtk installed because of emacs. I'll add it to the rundeps if no one will overtake me.

Thanks, Fabio. I feel it's a brand new dependency because the new GUI and the ability to search for games online inside Lutris, a feature it hadn't before.

JoshStrobl moved this task from Backlog to Package Fixes on the Software board.Feb 3 2019, 6:43 PM

Not sure why you would mark this as resolved given the rundep wasn't yet added.

Sorry, it's true.
Cheers.

Jacalz added a subscriber: Jacalz.Feb 3 2019, 7:58 PM

I will go ahead and get this fixed as soon as possible

Well if you want to go ahead, make sure to run tests on your local installation (it's not possible to run tests inside solbuild as there's no screen output, so they fail) to make sure we're listing every dependency.

Jacalz added a comment.Feb 3 2019, 8:07 PM

I figured that I would just add the dependency but I don't really know how to do any other tests than starting the program. I have MATE on my build machine so I can't test Plasma :I

Drop a patch. I'll take care of the rest.

Jacalz added a comment.Feb 3 2019, 8:10 PM

Sure, will do 👍

Jacalz added a comment.Feb 3 2019, 8:23 PM
This comment was removed by Jacalz.