Page MenuHomeSolus

Module dm-raid not found
Closed, ResolvedPublic

Description

While I was trying to create a mirror set with lvm, I was stopped by this error:

root@impact ~ # lvcreate -m 1 -L 10.9T -n Sphere Shapes /dev/mapper/12TBa1 /dev/mapper/12TBb1
modprobe: FATAL: Module dm-raid not found in directory /lib/modules/4.20.3-108.current
  /sbin/modprobe failed: 1
  raid1: Required device-mapper target(s) not detected in your kernel.
  Run `lvcreate --help' for more information.

This was intended to be the first mirror set I put into my system, so I haven't actually seen this work in Solus before. I found this forum thread with someone running into a similar problem (lvm+raid5), but as far as I can tell, there was no follow-up bug report.

jbelivea created this task.Jan 30 2019, 6:50 AM

The dm-raid module is indeed disabled in our kernel, see here. I'm not sure why this is exactly the case, but it looks like using software RAIDs with mdraid is the preferred option nowadays - at least the Arch wiki is saying the following:

dmraid is currently unmaintained and might break with new linux versions. Using mdadm is highly recommended.

Of course we can still ask @DataDrake if he wants to enable the kernel module.

Well, if that's the case, I wouldn't want unmaintained code enabled on my behalf. I was only using the raid flags in lvm because I was going by memory how to set that up; but if it's all now built on deprecated code now, I can just as well use mdadm.

@der_eismann I'm not entirely sure that is correct. It isn't considered experimental (LKDDB isn't correct, I looked at the Kconfig myself and it was moved from experimental clear back in 2013) and dm-raid.c has seen fairly active development going back to late December. I wouldn't really consider Arch Linux to be any sort of authority on the matter.

JoshStrobl edited projects, added Software; removed Lacks Project.Jan 30 2019, 2:09 PM

They surely aren't any authority, it was just the best I could find on this topic. But LKDDB is correct - the module was experimental in Linux 2.6.38-3.3. When you scroll down a bit you can see it isn't experimental anymore and also supports more RAID levels in the latest kernels.
As a personal opinion I would always prefer a software RAID over a desktop chipset RAID, but that doesn't matter. Let the team decide whether to include it or not :)

JoshStrobl moved this task from Backlog to Improvement on the Software board.Feb 12 2019, 7:45 AM
JoshStrobl assigned this task to DataDrake.

I'm going to leave it up to @DataDrake. Personally I don't care but it would make software raids easier and I won't pretend there isn't a usecase for a desktop with multiple drives in RAID.

DataDrake triaged this task as High priority.Mar 2 2019, 3:42 AM

Someone remind me if I forget tomorrow.

DataDrake closed this task as Resolved.May 5 2019, 6:45 PM

Added to linux-current and linux-lts