Page MenuHomeSolus

s-tui
Closed, ResolvedPublic

Description

name: s-tui
homepage: https://github.com/amanusk/s-tui
Why should this be included in the repository?
(this is taken from its page)

  • Monitoring your CPU temperature/utilization/frequency/power
  • Shows performance dips caused by thermal throttling
  • Requires minimal resources
  • Requires no X-server
  • Built in options for stressing the CPU (stress/stress-ng)
  • s-tui is not a processes monitor like htop. The purpose is to monitor your CPU statistics and have an option to test the system under heavy load. (Think AIDA64 stress test, not task manager).

my opinion about this tool: this tool is really useful when undervolting my laptop because I can stress and monitoring the CPU at the same time. This tool should be useful for other people who want undervolting or overclocking the CPUs. I'm not sure if it's tested on AMD CPU, but the author said it supports Intel Core 2nd gen and newer.
Is it open source? Under GPL 2.0. This is the latest version https://github.com/amanusk/s-tui/archive/v0.8.3.tar.gz

Related Objects

Event Timeline

riposte created this task.Jan 27 2019, 4:10 PM

What about CPU-x which we have in the repo?

What about CPU-x which we have in the repo?

TIL there is something like CPU-Z from Windows on Linux.
Not an exact replacement because it doesn't have graphs to monitoring things that related to CPU (frequency, utilization, temperature, CPU TDP) in one package.

I already tried to compile it by myself this morning and it works. What I need is pip, python3-urwid, and python-psutil from the repository.

please evaluate whether my request will be useful for some users or just for a few users (like me), I agree reducing unnecessary package to maintained will reducing the workload for maintainers.

JoshStrobl triaged this task as Wishlist priority.Jan 29 2019, 11:36 AM
JoshStrobl moved this task from Backlog to Awaiting Package Upgrades on the Package Requests board.
JoshStrobl added a subscriber: JoshStrobl.

These are all marked pre-release. Not going in until there is a stable release.

JoshStrobl renamed this task from (package request) s-tui; terminal-based CPU stress and monitoring utility to s-tui.Jan 29 2019, 11:36 AM
DataDrake closed this task as Wontfix.May 7 2019, 4:40 PM
DataDrake added a subscriber: DataDrake.

This hasn;t seen a new release in almost 6 months and is still marked as pre-release. Closing until that situation changes.

Has seen stable release.

nazar added a subscriber: nazar.Jan 19 2022, 11:36 AM
nazar added a comment.Jan 20 2022, 6:27 AM

sent patch for 1.1.3