Page MenuHomeSolus

anki won't start
Closed, InvalidPublic

Description

anki, version: 2.1.8, release: 3 quits with message of not supported QT version (e.g. 5.9, 5.11+). Disabling this sanity check doesn't produce good results either, binary crashes, here's a stack-trace just in case https://www.hastebin.com/oqilutizik.shell While snap has no anki packaged, there's binary packaged by app author at github releases page, it packages it's dependencies so it works as a workaround.

I'm not sure if it is upstream problem or not, if it is please close this task.

Event Timeline

nazar created this task.Jan 20 2019, 7:12 PM

I'll take a look, since it worked fine on my PC.

Weird, works fine on my fresh Solus Unstable VM, my Solus Unstable PC, and my Solus Stable laptop. Also that check should be gone since version 2.1.6 (see this commit: https://github.com/dae/anki/commit/3cb073878a13079185be8fde9f70401da297bbdf) (the version that allowed initial inclusion into the Solus repo). Could you try a reinstall of anki perhaps? Not sure what is happening here.

Girtablulu edited projects, added Software; removed Lacks Project.Jan 21 2019, 1:46 AM
nazar added a comment.Jan 21 2019, 6:40 PM

Closing this issue as invalid. Problem was local: eopkg check reported broken python3-qt5, and reinstall of anki and other packages that depend on broken one fixed the issue.

nazar closed this task as Invalid.Jan 21 2019, 6:41 PM