Page MenuHomeSolus

VirtualBox won't download guest additions when inserting to guest
Open, Needs TriagePublic

Description

Since the VirtualBox 6 update, when downloading guest additions for guest systems this error pops up: The network operation failed with the following error: During network request: Unknown reason.

Event Timeline

kyrios123 closed this task as Invalid.Jan 16 2019, 6:24 AM
kyrios123 added a subscriber: kyrios123.

Only installation of the vbox guest from the repository packages is supported.

https://getsol.us/articles/software/virtualbox/en/#solus-as-guest

This is a built in functionality of VirtualBox? Let me explain the scenario more clearly.

You have a guest VM in Solus, you enter the device menu and select "Insert guest additions" and the error occurs. It does not attempt to install guest additions for Solus, it aims to install for the guest system (Windows 7 in my case).

kyrios123 reopened this task as Open.Feb 3 2019, 10:56 AM
kyrios123 claimed this task.

Okay it appears to be a problem with non-solus guest VM too (which may not have them packaged in their repository), so the problem should be addressed.

kyrios123 changed the task status from Open to In Progress.Feb 3 2019, 10:57 AM
abdulocracy reopened this task as Open.EditedJul 29 2019, 12:02 AM

The issue is still present in the current Virtualbox package, the first time I tried inserting the quest additions image it failed to download, and the second time it outright crashed and aborted the VM. :/

Justin added a subscriber: Justin.Jul 29 2019, 1:14 AM

Can't figure out why this won't download. In the interim, you can download the version that matches VirtualBox from http://download.virtualbox.org/virtualbox/ and add it in Virtual Media Manager (under the File menu). Doesn't matter where it is stored as long as it's added in there. Have tested with a VM and it loads the Guest Tools CD.

@abdulocracy which OS are you running on the guest machine?
If it's windows, I can't test because I don't have a license.

@kyrios123 Windows 10, although the issue is also present on a fresh Ubuntu 18.04 guest machine.
You don't need a license, Microsoft provides free VMs for developers.

Guest OS doesn't really matter, can do it in any, it's the same ISO for all guests. It downloads then fails at 100%, when the ISO is available all it does it enter it into the drive for the guest.

@Justin it is a weird problem with our package that causes the guest additions ISO to fail before it reaches 100% when it's automatically downloaded/installed from the UI.
For Solus guests it's not an issue since the guest additions should be installed from the repository, but for others guest OS it's annoying.

The workaround consist of downloading the guest ISO from the official site and to mount it manually in the guest optical drive, but it is not user friendly and it should not happen anyway.

We had this problem a while ago. I did struggle a lot with it to finally get it back working but for some reason it's broken again. It's probably caused by one of the patch we apply. We should try it on a non patched build.