Page MenuHomeSolus

[RFC] Needs New Maintainer: ipscan
Closed, ResolvedPublic

Description

This package has been deemed to not be adequately maintained or integrated into the Solus repositories and/or Solus software stack as per T7318: End of Year Cleaning.

Basic Information:

Event Timeline

Herald triaged this task as High priority. · View Herald TranscriptJan 9 2019, 9:10 PM

This package has been marked by a Core Team member for planned deprecation. In this case, Planned Deprecation means that this package will be removed from our repository in the event no individual comes forward to maintain this package. Such Planned Deprecation will occur no less than 30 days from the adding of this tag.

If you wish to become the dedicated package maintainer for this package, please bear in mind that this package has been marked as a result of being either poorly integrated or maintained. If you are intent on becoming the maintainer for this package, please do so with:

  1. The expectation that you will be responsible for actively maintaining and integrating this package into the rest of the Solus software stack.
  2. The expectation that you will need to respond to issues related to this package in a timely manner.
  3. The expectation that you will be or already are actively using this package as part of your workflow, whether on a irregular or regular basis.

In the event you wish to become a package maintainer for this, please comment that you will be stepping forward to do so. This way, a Core Team member, or a member of the Triage Team, can remove the Planned Deprecation tag.

chax added a subscriber: chax.Apr 24 2019, 7:57 PM

I volunteer as maintainer.

chax added a comment.Apr 24 2019, 8:00 PM

I also see that there is newer version available, so i will try to update it to 3.5.5 and submit patch

@chax Any update on this?

chax added a comment.Jun 12 2019, 12:57 PM

Yes, tried to update package.yml and then i realized that ipscan changed the way it builds. Now it uses gradle (gradle wrapper) to build.
There are a couple of problems with new build system.
Gradle wrapper doesn't work at all inside solbuild, having some network issues, not being able to download gradle zip.

This is the error that i get when running make with new package.yml definition:

./gradlew info
Downloading https://services.gradle.org/distributions/gradle-4.10.2-bin.zip

Exception in thread "main" java.net.UnknownHostException: services.gradle.org
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
	at java.net.Socket.connect(Socket.java:589)
	at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:666)
	at sun.security.ssl.BaseSSLSocketImpl.connect(BaseSSLSocketImpl.java:173)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
	at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264)
	at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1156)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1050)
	at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1492)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:263)
	at org.gradle.wrapper.Download.downloadInternal(Download.java:66)
	at org.gradle.wrapper.Download.download(Download.java:51)
	at org.gradle.wrapper.Install$1.call(Install.java:62)
	at org.gradle.wrapper.Install$1.call(Install.java:48)
	at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAccessManager.java:69)
	at org.gradle.wrapper.Install.createDist(Install.java:48)
	at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:107)
	at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:61)
make: *** [Makefile:5: info] Error 1

I tried to build this without solbuild by just cloning git repository and running their make directly and this way it works, but i needed to install both rpm and dpkg packages to be able to do that.
Their gradle.build is configured to package both rpm and deb packages if platform is linux(64). This can be avoided by patching gradle.build file and removing deb and rpm targets, but i still can't run gradle inside solbuild.

I think the problem is that java is sandboxed in a way that it can't access internet from inside solbuild, but i don't know enough of solbuild to find/fix this problem.

@chax Did you enable network in solbuild by setting networking : yes in your package.yml file?

chax added a comment.Jun 12 2019, 2:23 PM

@xulongwu4, thanks for the tip, i wasn't aware of this option, it works now.
I just need to cleanup a bit and i will submit the patch when i'm done.

JoshStrobl closed this task as Resolved.Jun 13 2019, 7:26 PM

Thanks for picking up maintainership of ipscan @chax

Macro youdarealmvp: